Bug 23673 - Installer fails to complete post install
Installer fails to complete post install
Status: CLOSED DUPLICATE of bug 19523
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-09 16:15 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-09 16:52:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-01-09 16:15:51 EST
Machine is a Compaq Proliant ML530 with a Smart Array 5300 controller 
(cciss driver).  12 Ultra3 18.2GB 15K RPM drives.  512MB of RAM.  Text 
install.  Tried partitioning with both FDISK and Disk Druid.  Used 
anaconda update from errata page.

Install goes just as planned until it begins the post install (after the 
partitions are formatted and the packages are all installed).  Gets to 
about half and produces the bug report below.  If I switch to the ALT+F4 
screen, the message "<4>Neighbour Table Overflow" is repeated at the end 8 
times.  

Checking with Compaq as well...

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1732, in 
doInstall
    self.upgrade)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/lilo.py", line 330, in 
install
    thisLabel = thisLabel + '-up'
TypeError: bad operand type(s) for +

Local variables in innermost frame:
thisLabel: None
mainLabelUsed: 1
upgrade: 0
main: None
images: {}
bootpart: cciss/c0d0p1^Q
smpInstalled: 1
liloTarget: cciss/c0d0p1^Q
boothd: cciss/c0d0
rootDev: cciss/c0d0p6^Q
fstab: <fstab.NewtFstab instance at 820afa8>
lilo: boot=/dev/cciss/c0d0p1^Q
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
message=/boot/message
default

perms: 420
self: <lilo.LiloConfiguration instance at 82756e8>
otherList: []
default: None
hdList: <comps.HeaderListFromFile instance at 8227e08>
kernelList: [(None, kernel-smp, 'smp')]
instRoot: /mnt/sysimage

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2001-01-09 16:52:16 EST

*** This bug has been marked as a duplicate of 19523 ***

Note You need to log in before you can comment on or make changes to this bug.