This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 236743 - anaconda states partitioning invalid and wants to repartition whole disk
anaconda states partitioning invalid and wants to repartition whole disk
Status: CLOSED DUPLICATE of bug 229745
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2007-04-17 10:29 EDT by David Timms
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-26 18:28:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
commonly requested info {bug 229704} (290 bytes, text/plain)
2007-04-17 10:29 EDT, David Timms
no flags Details
hp compaq nx6320 sata disk fc6 lspci (2.10 KB, text/plain)
2007-04-17 10:56 EDT, David Timms
no flags Details
hp compaq nx6320 sata disk fc6 lspcmcia (60 bytes, text/plain)
2007-04-17 10:56 EDT, David Timms
no flags Details
hp compaq nx6320 sata disk fc6 dmesg (28.04 KB, text/plain)
2007-04-17 10:58 EDT, David Timms
no flags Details
hp compaq nx6320 sata disk f devel lspci (2.16 KB, text/plain)
2007-04-17 11:24 EDT, David Timms
no flags Details
hp compaq nx6320 sata disk f devel dmesg (16.00 KB, text/plain)
2007-04-17 11:24 EDT, David Timms
no flags Details
with loglevel=debug as a boot parameter? Attach /tmp/anaconda.log with loglevel=debug boot param (17.38 KB, text/plain)
2007-04-18 05:51 EDT, David Timms
no flags Details
rescue iso installer wants to initialize disk, same failure {nodmraid not set} (21.00 KB, text/plain)
2007-04-19 18:43 EDT, David Timms
no flags Details
installer log with: loglevel=debug nodmraid (18.38 KB, text/plain)
2007-04-19 18:44 EDT, David Timms
no flags Details
fdisk -l (722 bytes, text/plain)
2007-04-19 18:47 EDT, David Timms
no flags Details
lsmod (1.87 KB, text/plain)
2007-04-19 18:48 EDT, David Timms
no flags Details
parted | fdisk -l | fdisc /dev/sda x (3.40 KB, text/plain)
2007-04-30 19:25 EDT, David Timms
no flags Details
dd sda first 1024 bytes (1.00 KB, application/octet-stream)
2007-04-30 19:29 EDT, David Timms
no flags Details

  None (edit)
Description David Timms 2007-04-17 10:29:13 EDT
Description of problem:
Incorrect detection of partition information, and subsequently wants to
partition the fedora core 6, erasing it, rather than upgrading it. Additionally,
seems to get through to the partition screen if you click retry, then has a
further error.

Version-Release number of selected component (if applicable):
rawhide 2007-04-17 08:31 pxeboot ftp install

How reproducible:
yes: hp compaq nx6320

Steps to Reproduce:
1. boot from network pxeboot
2. ftp method
  
Actual results:
I need to redo to get actual message...

Expected results:
Should detect existing working operating partition info from the disk, and offer
to upgrade.

Additional info:
Comment 1 David Timms 2007-04-17 10:29:14 EDT
Created attachment 152809 [details]
commonly requested info {bug 229704}
Comment 2 David Timms 2007-04-17 10:56:09 EDT
Created attachment 152811 [details]
hp compaq nx6320 sata disk fc6 lspci
Comment 3 David Timms 2007-04-17 10:56:52 EDT
Created attachment 152812 [details]
hp compaq nx6320 sata disk fc6 lspcmcia
Comment 4 David Timms 2007-04-17 10:58:01 EDT
Created attachment 152813 [details]
hp compaq nx6320 sata disk fc6 dmesg
Comment 5 David Timms 2007-04-17 11:22:54 EDT
The message is:
Warning
The partition table on device sda was unreadable. To create new partition it
must be initialized, causing the loss of ALL DATA on this drive.

This operation will override any previous isntallation choices about which
drives to ignore.

Would you like to initialize this drive, erasing ALL DATA ?

No  {default- thankgod}  Yes.
---
click No
Searching for fedora core installations
back to warning dialog
Click No
Create custom layout | next

dialog:
No Drives Found
An error has occurred - no valid device were found on which to create new file
systems. Please check your hardware for the cause of this problem.
===
This second message should be more like: ~"we have a bug that meant anaconda
could not detect and mount the /dev/sda device. Please submit a bug report at
bugzilla.redhat.com"

This is a fedora core 6 system. The partitions are ntfs fat32 boot, extended,
root swap etc. The NTFS partition was downsized with a circa 2006 gparted.
Comment 6 David Timms 2007-04-17 11:24:06 EDT
Created attachment 152820 [details]
hp compaq nx6320 sata disk f devel lspci
Comment 7 David Timms 2007-04-17 11:24:49 EDT
Created attachment 152821 [details]
hp compaq nx6320 sata disk f devel dmesg
Comment 8 David Cantrell 2007-04-17 13:25:27 EDT
Can you try again with loglevel=debug as a boot parameter?  Attach
/tmp/anaconda.log to this bug report.
Comment 9 David Timms 2007-04-18 05:51:21 EDT
Created attachment 152882 [details]
with loglevel=debug as a boot parameter?  Attach
/tmp/anaconda.log with loglevel=debug boot param

on a side note: the rescue cd set to ftp install fails as well (cant mount the
downloaded img), but that may be a separate issue.
Comment 10 David Cantrell 2007-04-19 15:09:40 EDT
This is odd.  I cannot reproduce the problem here.  Can you try passing the
'nodmraid' boot option to the installer and see if the problem persists?
Comment 11 David Timms 2007-04-19 18:43:02 EDT
Created attachment 153071 [details]
rescue iso installer wants to initialize disk, same failure {nodmraid not set}

2007-04-19 release 2!
-rw-r--r-- 1 root root 103387136 Apr 19 14:21 FC-development-i386-rescuecd.iso
-rw-r--r-- 1 root root	 5779339 Apr 19 14:19 initrd.img
-rw-r--r-- 1 root root	     270 Apr 19 14:19 README
-rw-r--r-- 1 root root	      75 Apr 19 14:21 SHA1SUM
-rw-r--r-- 1 root root	 1919988 Apr 19 14:19 vmlinuz
Comment 12 David Timms 2007-04-19 18:44:27 EDT
Created attachment 153072 [details]
installer log with: loglevel=debug nodmraid

The nodmraid parameter does not make any difference to the issue.
Comment 13 David Timms 2007-04-19 18:47:39 EDT
Created attachment 153073 [details]
fdisk -l
Comment 14 David Timms 2007-04-19 18:48:36 EDT
Created attachment 153074 [details]
lsmod

both the logs are from vt2 when installer has excepted.
Comment 15 David Timms 2007-04-30 11:11:19 EDT
Didn't realise I needed to comment to unset need info...
Comment 16 Jeremy Katz 2007-04-30 14:54:26 EDT
Cna you provide what parted thinks the disk looks like?  Since that's almost
certainly where the problem lies
Comment 17 David Timms 2007-04-30 19:25:07 EDT
Created attachment 153845 [details]
parted | fdisk -l | fdisc /dev/sda x

Notice that fdisk is happy about the partition scheme, and it is what is
actually used for this dual boot winxp+fc6 machine.

The original winxp ntfs partition was shrunk with gparted, and the other
partitions created. There is no other visible side effect from parted from not
liking it.
Comment 18 David Timms 2007-04-30 19:29:30 EDT
Created attachment 153846 [details]
dd sda first 1024 bytes
Comment 19 David Cantrell 2007-09-26 18:28:38 EDT
I've created your partition layout exactly as you specify both by hand and by
using the dd image you provided.  In rawhide (soon to F-8), parted is not
showing any errors when reading this disk label.  The partitions are all
detected and appear in anaconda just fine.

I'm marking this as a dupe of bug #229745 because it appears to be the exact
same problem.  I patched parted to fix that bug and that's what I'm using here
to try to reproduce your problem.

*** This bug has been marked as a duplicate of 229745 ***

Note You need to log in before you can comment on or make changes to this bug.