Bug 229745 - Working hard drive detected as no partition table - exception encountered
Working hard drive detected as no partition table - exception encountered
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Brock Organ
:
: 236743 (view as bug list)
Depends On: 241288
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-22 22:27 EST by Jim Cornette
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-13 11:05:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
This is the dump encountered. (51.36 KB, text/plain)
2007-02-22 22:27 EST, Jim Cornette
no flags Details

  None (edit)
Description Jim Cornette 2007-02-22 22:27:14 EST
Description of problem:

When attempting to perform an upgrade, anaconda wanted to initialize my hard
disk. I did not allow the hard drive to be initialized since it has both windows
XP and this FC6 version that I am using right now.

Version-Release number of selected component (if applicable):
anaconda - whatever detects hard disks.

How reproducible:

Start installer, do not allow hd initialization for hda. (sda in FC7). Let the
installer perform its next action.

Steps to Reproduce:
1. Select upgrade or install menu choice.
2. read message that no partition table detected on drive
3. choose not to initialize hard disk.
  
Actual results:

Anaconda allowed the saving to floppy of the exception.


Expected results:

Detecting the hard disk correctly and upgrading one of my installations. (FC6 on
hda and Fedora development on hdb)

Additional info:

I have a problem where FC6 has a swap lvm which will not mount when using Fedora
development. The development version spits out errors related to reading past
end of disk. fdisk -l shows below information.

bug 220535 covers the lvm swap problem with mounting in development. This is
just for possible reference and not expand the problem scope.
Comment 1 Jim Cornette 2007-02-22 22:27:15 EST
Created attachment 148643 [details]
This is the dump encountered.
Comment 2 Jim Cornette 2007-02-22 22:28:14 EST
adding output from fdisk -l (in FC6)

 fdisk -l

Disk /dev/hda: 60.0 GB, 60022480896 bytes
255 heads, 63 sectors/track, 7297 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        3000    24097468+   7  HPFS/NTFS
/dev/hda2            3001        3013      104422+  83  Linux
/dev/hda3            3014        5563    20482875   83  Linux
/dev/hda4            5564        7297    13928355    5  Extended
/dev/hda5            5564        7297    13928323+  8e  Linux LVM
Comment 3 Jim Cornette 2007-02-23 17:53:21 EST
This problem with the partition table seems to be at least common with two
people, myself and this poster to the test list. See url below:
https://www.redhat.com/archives/fedora-test-list/2007-February/msg00586.html

Also, the partition table for development is posted below;
Disk /dev/sda: 56.9 GB, 56902596096 bytes
255 heads, 63 sectors/track, 6918 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        3000    24097468+   7  HPFS/NTFS
/dev/sda2            3001        3013      104422+  83  Linux
/dev/sda3            3014        5563    20482875   83  Linux
/dev/sda4            5564        7297    13928355    5  Extended
/dev/sda5            5564        7297    13928323+  8e  Linux LVM

Disk /dev/sdb: 80.0 GB, 80026361856 bytes
16 heads, 63 sectors/track, 155061 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1         195       98248+  83  Linux
/dev/sdb2             196       97077    48828528   83  Linux
/dev/sdb3           97078       98070      500472   82  Linux swap / Solaris
/dev/sdb4           98071      155061    28723464   83  Linux
Comment 4 Jeremy Katz 2007-02-26 14:57:34 EST
What does parted say about the disk?
Comment 5 Jim Cornette 2007-02-26 22:54:34 EST
Running development and parted-1.8.2-5.fc7. I am not too familiar with parted,
so I hope this is what you wanted.

]# parted /dev/sda print
Error: Can't have a partition outside the disk!                           
Information: Don't forget to update /etc/fstab, if necessary.             

]# parted /dev/sdb print
Model: ATA WDC WD800JB-00JJ (scsi)
Disk /dev/sdb: 80.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      32.3kB  101MB   101MB   primary  ext3         boot 
 2      101MB   50.1GB  50.0GB  primary  ext3              
 3      50.1GB  50.6GB  512MB   primary  linux-swap        
 4      50.6GB  80.0GB  29.4GB  primary  ext3              

Information: Don't forget to update /etc/fstab, if necessary.   
Comment 6 Jim Cornette 2007-02-26 23:21:23 EST
Freom the FC6 side and using parted-1.8.1-1.fc6, I get the below results with
parted.

]# parted /dev/hda print

Model: ST360015A (ide)
Disk /dev/hda: 60.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system  Flags
 1      32.3kB  24.7GB  24.7GB  primary   ntfs         boot 
 2      24.7GB  24.8GB  107MB   primary   ext3              
 3      24.8GB  45.8GB  21.0GB  primary   ext3              
 4      45.8GB  60.0GB  14.3GB  extended                    
 5      45.8GB  60.0GB  14.3GB  logical                lvm  

Information: Don't forget to update /etc/fstab, if necessary.             

]# parted /dev/hdb print

Model: WDC WD800JB-00JJC0 (ide)
Disk /dev/hdb: 80.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      32.3kB  101MB   101MB   primary  ext3         boot 
 2      101MB   50.1GB  50.0GB  primary  ext3              
 3      50.1GB  50.6GB  512MB   primary  linux-swap        
 4      50.6GB  80.0GB  29.4GB  primary  ext3              

Information: Don't forget to update /etc/fstab, if necessary.             

Comment 7 Bill Nottingham 2007-03-02 12:34:04 EST
Moving to 'devel' as discussed on
https://www.redhat.com/archives/fedora-devel-list/2007-March/msg00095.html.
Comment 8 Jim Cornette 2007-03-20 17:35:29 EDT
Withe the updated parted-1.8.5-1.fc7 version, I still get errors with the disk
recognition for a working hard disk.

 parted /dev/sda print
Error: Can't have a partition outside the disk!                           
Information: Don't forget to update /etc/fstab, if necessary.             

[root@cornette-dell-hdb ~]# parted /dev/sdb print
Model: ATA WDC WD800JB-00JJ (scsi)
Disk /dev/sdb: 80.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system      Flags
 1      32.3kB  101MB   101MB   primary  ext3             boot 
 2      101MB   50.1GB  50.0GB  primary  ext3                  
 3      50.1GB  50.6GB  512MB   primary  linux-swap(new)       
 4      50.6GB  80.0GB  29.4GB  primary  ext3                  

Information: Don't forget to update /etc/fstab, if necessary.   
Comment 9 David Cantrell 2007-04-11 15:52:02 EDT
Can you try parted-1.8.6-4.fc6 to see if it can read your disks correctly?  I
have built this is a special package for you to try:

http://people.redhat.com/dcantrel/RPMS/parted/

Install on FC-6 and run it to see if the print command works.  This package will
most likely conflict with pyparted and maybe other things.  Easiest thing to do
is force install it using --nodeps on rpm.  Once you have performed the test to
see if print works, remove the parted-1.8.6-4 packages using 'rpm -e --nodeps'.
 Run 'yum install parted' to reinstall the correct parted for FC-6.
Comment 10 Jim Cornette 2007-04-11 20:59:51 EDT
The version in FC6 worked as the version in the repo. Both gave the same results.
Anything after FC6 will not install via anaconda because it wants to initialize
the first disk /dev/hda (/dev/sda in development)
FC7 version of parted gives errors. I figured it would but thought I'd try
anyway and include results.

 parted /dev/hda print
Model: ST360015A (ide)
Disk /dev/hda: 60.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system  Flags
 1      32.3kB  24.7GB  24.7GB  primary   ntfs         boot 
 2      24.7GB  24.8GB  107MB   primary   ext3              
 3      24.8GB  45.8GB  21.0GB  primary   ext3              
 4      45.8GB  60.0GB  14.3GB  extended                    
 5      45.8GB  60.0GB  14.3GB  logical                lvm  

Information: Don't forget to update /etc/fstab, if necessary.             

[root@dell-cornette ~]# cd /home/erin/parted-misdiagnose/
[root@dell-cornette parted-misdiagnose]# rpm -Uvh *.rpm --nodeps
Preparing...                ########################################### [100%]
   1:parted                 ########################################### [100%]
[root@dell-cornette parted-misdiagnose]# parted /dev/hda print
Model: ST360015A (ide)
Disk /dev/hda: 60.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system  Flags
 1      32.3kB  24.7GB  24.7GB  primary   ntfs         boot 
 2      24.7GB  24.8GB  107MB   primary   ext3              
 3      24.8GB  45.8GB  21.0GB  primary   ext3              
 4      45.8GB  60.0GB  14.3GB  extended                    
 5      45.8GB  60.0GB  14.3GB  logical                lvm  

Information: Don't forget to update /etc/fstab, if necessary.             

[root@dell-cornette parted-misdiagnose]# rpm -e parted --nodeps
[root@dell-cornette parted-misdiagnose]# yum install parted
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
updates                                                         1.2 kB 00:00 
core                      100% |=========================| 1.1 kB    00:00     
updates-testing           100% |=========================| 1.2 kB    00:00     
extras                    100% |=========================| 1.1 kB    00:00     
Reading repository metadata in from local files
primary.xml.gz                                                  502 kB 00:01 
updates   : ################################################## 1215/1215
primary.xml.gz            100% |=========================|  58 kB    00:00     
updates-te: ################################################## 77/77
primary.xml.gz            100% |=========================| 1.6 MB    00:03     
extras    : ################################################## 5139/5139
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for parted to pack into transaction set.
parted-1.8.2-2.fc6.i386.r 100% |=========================|  25 kB    00:00     
---> Package parted.i386 0:1.8.2-2.fc6 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 parted                  i386       1.8.2-2.fc6      updates           534 k

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 534 k
Is this ok [y/N]: y
Downloading Packages:
(1/1): parted-1.8.2-2.fc6.i386.rpm                              534 kB 00:01 
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: parted                       ######################### [1/1] 

Installed: parted.i386 0:1.8.2-2.fc6
Complete!
[root@dell-cornette parted-misdiagnose]# rpm -Uvh *.rpm --nodeps
Preparing...                ########################################### [100%]
   1:parted                 ########################################### [100%]
[root@dell-cornette parted-misdiagnose]# parted /dev/hda print
parted: error while loading shared libraries: libtinfo.so.5: cannot open shared
object file: No such file or directory
Comment 11 David Cantrell 2007-04-12 10:49:57 EDT
(In reply to comment #10)
> The version in FC6 worked as the version in the repo. Both gave the same results.
> Anything after FC6 will not install via anaconda because it wants to initialize
> the first disk /dev/hda (/dev/sda in development)
> FC7 version of parted gives errors. I figured it would but thought I'd try
> anyway and include results.

I'm not sure I explained my NEEDINFO request very well.  What I did was build
the rawhide parted with a new patch (which may or may not fix the problem you've
reported, hence wanting you to test it out) for FC-6.  Based on your comments in
this bug report, I am assuming you have a working FC-6 install.  What I wanted
you to do was install parted-1.8.6-4.fc6 from this location:

http://people.redhat.com/dcantrel/RPMS/parted/

On your FC-6 system.  You will get rpm dependency conflicts, but it's ok for
this test.  Just get parted-1.8.6-4.fc6 to install on your FC-6 side and then run:

parted /dev/hda print

I want to know if the patch I've added works.

Once you have performed the test, post the results here.  To reset your FC-6
system back to the current released parted rpm for FC-6, simply use 'rpm -e
--nodeps' to remove parted-1.8.6-4.fc6 that you force-installed for the test. 
Then use 'yum install parted' to let it pull to FC-6 parted back from the
repository.

The key to this test is running 'parted /dev/hda print' using the
parted-1.8.6-4.fc6 package from the URL above.
Comment 12 Jim Cornette 2007-04-12 19:59:22 EDT
Sorry for the lack of clarity.
The version that is part of FC6 is below:
parted /dev/hda print
Model: ST360015A (ide)
Disk /dev/hda: 60.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system  Flags
 1      32.3kB  24.7GB  24.7GB  primary   ntfs         boot 
 2      24.7GB  24.8GB  107MB   primary   ext3              
 3      24.8GB  45.8GB  21.0GB  primary   ext3              
 4      45.8GB  60.0GB  14.3GB  extended                    
 5      45.8GB  60.0GB  14.3GB  logical                lvm  

Information: Don't forget to update /etc/fstab, if necessary.             

---

Your version for test results are below. There is no difference that I can see.

 parted /dev/hda print
Model: ST360015A (ide)
Disk /dev/hda: 60.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system  Flags
 1      32.3kB  24.7GB  24.7GB  primary   ntfs         boot 
 2      24.7GB  24.8GB  107MB   primary   ext3              
 3      24.8GB  45.8GB  21.0GB  primary   ext3              
 4      45.8GB  60.0GB  14.3GB  extended                    
 5      45.8GB  60.0GB  14.3GB  logical                lvm  

Information: Don't forget to update /etc/fstab, if necessary.

FC6 System is back to the original state.
Comment 13 David Cantrell 2007-04-13 11:05:18 EDT
It looks like the patch I added fixed up the problem.  Building a new
parted-1.8.6-4.fc7 in to rawhide and closing the bug.

Thanks for testing things out for me.
Comment 14 Jim Cornette 2007-04-14 19:52:50 EDT
No problem testing out te patch. I will try F7T4 to see if installation is
possible with the working FC6 still present on the primary disk.
Comment 15 Jim Cornette 2007-05-09 18:02:23 EDT
Fedora test four shows the below error message.

 --------------------- Kernel Begin ------------------------


 WARNING:  Kernel Errors Present
    Buffer I/O error on device sda5,  ...:  36 Time(s)
    rtc_cmos: probe of 00:05 failed with error -16 ...:  2 Time(s)

 ---------------------- Kernel End -------------------------
Comment 16 David Cantrell 2007-05-10 09:58:34 EDT
(In reply to comment #15)
> Fedora test four shows the below error message.
> 
>  --------------------- Kernel Begin ------------------------
> 
> 
>  WARNING:  Kernel Errors Present
>     Buffer I/O error on device sda5,  ...:  36 Time(s)
>     rtc_cmos: probe of 00:05 failed with error -16 ...:  2 Time(s)
> 
>  ---------------------- Kernel End -------------------------
> 

You need to open a new bug for Fedora devel for the kernel component and detail
the sda problems you are having.
Comment 17 Jim Cornette 2007-05-10 20:26:47 EDT
I believe that I have two kernel bugs opened against the hard drive problem.
This problem was encountered when trying to install F7T1. I have no problems
using the development version since I do not mount /dev/sda often except to get
information periodically.

Basically, when trying to install from media, it wants to reformat my working
FC6 installation. Also the swap file within the lvm for FC6 is not accessible. I
get errors on bootup about reading past the end of the disk.

I get the below message repeatably in dmesg.

attempt to access beyond end of device
sda: rw=0, want=117226171, limit=111137883
printk: 86 messages suppressed.
Buffer I/O error on device sda5, logical block 27856512
attempt to access beyond end of device
sda: rw=0, want=117226172, limit=111137883
Buffer I/O error on device sda5, logical block 27856513
attempt to access beyond end of device
sda: rw=0, want=117226173, limit=111137883
Buffer I/O error on device sda5, logical block 27856514
attempt to access beyond end of device
sda: rw=0, want=117226174, limit=111137883
Buffer I/O error on device sda5, logical block 27856515
attempt to access beyond end of device
sda: rw=0, want=117226175, limit=111137883
Buffer I/O error on device sda5, logical block 27856516
attempt to access beyond end of device
sda: rw=0, want=117226176, limit=111137883
Buffer I/O error on device sda5, logical block 27856517
attempt to access beyond end of device
sda: rw=0, want=117226177, limit=111137883
.... (Prints out one by one, about 128 entries)
sda: rw=0, want=117226305, limit=111137883
Comment 18 David Cantrell 2007-09-26 18:28:39 EDT
*** Bug 236743 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.