Bug 236767 - After install using rhgb don´t reach my desktop
After install using rhgb don´t reach my desktop
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks: 427887
  Show dependency treegraph
 
Reported: 2007-04-17 12:00 EDT by Mario Lopez
Modified: 2008-01-09 09:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-09 09:54:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ScreenShot (90.03 KB, image/jpeg)
2007-04-17 12:00 EDT, Mario Lopez
no flags Details

  None (edit)
Description Mario Lopez 2007-04-17 12:00:41 EDT
Description of problem:
When Install Fedora Core 6 x86_64 and use the rhgb never reach the gnome
Desktop, only the drivers are loaded but the system stop, after remove the rhgb
in the grub.conf I can reach the gnome desktop, but when logoff the system crash.
First the behavior seems like the bug #122031 but only in some aspects as
keyborad, screens died etc. but I get some fail code...

...............
...............
[<ffffffff80223b22>] filp_close+0x5c/0x64
[<ffffffff8021d82b>] sys_close+0x8f/0xaa
[<ffffffff8025c00e>] system_call+0x7e/0x83

Code: 85 c0 7f 55 48 ff c2 48 39 ea 75 f0 85 c9 74 e8 c9 74 e8 e8 9e 3e 08
console shut up ...

Steps to Reproduce:
1. Install Fedora Core 6 x86_64
2. Boot after Install with rhgb enabled by default
3. Gnome Desktop isn´t reached.
  
Additional info:

Using Display Driver i810 with default configuration.
Comment 1 Mario Lopez 2007-04-17 12:00:41 EDT
Created attachment 152828 [details]
ScreenShot
Comment 2 Adam Jackson 2007-05-03 18:48:18 EDT
Panic means kernel bug...
Comment 3 Mario Lopez 2007-05-04 10:57:30 EDT
But the VESA driver all works Fine, ... don't have this problem, it's say me
that the kernel doesn´t have a bug. what doy U think ?

It happens only with AMD64 port, before I was using x86 port and all work great,
I have an EMT64 capable processor and runs debian great, all services work fine
except xserver-xorg with driver i810, let me say that the error is just when
unloading X, before that I can reach my desktop, use the Render, 3D accel,
Composite Extension, Compiz etc but when Shuts down the Computer I get a Kernel
Panic, I think to set the driver to VESA and work but haven´t DRI, 3D Accel,
Composite etc.

My Hardware is:

- Celeron D 3.6 GHz EMT64
- ASRock 775i65G
- Intel® 865G Chipset
- Integrated Intel® Extreme Graphics 2 (intel 82865G Graphics)


The error screen message wite some like:
********************CODE**********************
[<ffffffff8004cf10>] thread_return+0x0/0xe7
[<ffffffff8004cf10>] vsf_write+0xe1/0x174
[<ffffffff8004cf10>] sys_write+0x45/0x6e
[<ffffffff8004cf10>] system_call+0x7e/0x83

Code: 4c 8b 20 48 89 c7 c4 89 63 40 ff 50 08 48 89 e8 89 ea 48 ff
RIP [ffffffff8028e424] __rcu_process_callbacks+0x115/0x1a8
RSP <ffffffff8004cf10>
CR2: ffffffff80a324c0
<0> Kernel Panic - not syncing: Aiee, killing interrupt handler!
********************END OF CODE**********************

I have put the one screenshoot here
http://bp0.blogger.com/_w833IbeIZhI/RjpWdCwgHwI/AAAAAAAAAA4/h4-Lba1UnCU/s1600-h/i810+crash.jpg
Comment 4 Chuck Ebbert 2007-05-04 13:12:44 EDT
Can you get this capture in 50-line screen mode?
(It may not work because it could go back to 25-line mode when X crashes.)
Boot with the kernel option "vga=ask" and select 80x50 mode.
Comment 5 Mario Lopez 2007-05-04 13:45:23 EDT
I'll send you as soon as posible but at this moment don't have near my PC, but
analizing two screenshot taken one of my Fedora Core Test 3 and other of Debian
Etch (two running in diferents Disks but same PC). I have noted that the two
crashes on 

[XXXXXXXX] system_call+07e/0x83

Does the call to this function means some special ?


[Screenshots]
Fedora Core Test 3
http://bp0.blogger.com/_w833IbeIZhI/Rjtv4ywgHyI/AAAAAAAAABI/77B4WcCZvEI/s1600-h/i810%2Bcrash%2Bfedora-test3.JPG

Debian Etch
http://bp2.blogger.com/_w833IbeIZhI/Rjtv1SwgHxI/AAAAAAAAABA/1nPPJihzYIw/s1600-h/i810%2Bcrash%2Bdebian%2Betch.jpg

Comment 6 Mario Lopez 2007-05-05 10:50:56 EDT
Here is the screenshot at widescreen mode

http://bp0.blogger.com/_w833IbeIZhI/RjyYxiwgHzI/AAAAAAAAABQ/hpyIEvlesNI/s1600-h/widescreen%2Bi810%2Bcrash.jpg
Comment 7 Jon Stanley 2008-01-07 20:55:01 EST
(This is a mass-update to all current FC6 kernel bugs in NEW state)

Hello,

I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!

Note You need to log in before you can comment on or make changes to this bug.