Bug 23681 - <limits> (and other?) autoconf-generated C++ headers missing from installation
Summary: <limits> (and other?) autoconf-generated C++ headers missing from installation
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libstdc++ (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-09 23:18 UTC by Andrew Trick
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-09 23:18:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew Trick 2001-01-09 23:18:28 UTC
Standard C++ header files appear to be missing from the distribution.

In particular, "/usr/include/g++-3/limits" is not installed.  This header 
will most likely depend on other C++ headers such as:
/usr/include/bits/c++config.h
/usr/include/bits/std_cfloat.h
/usr/include/bits/std_climits.h
- I'm not sure about the installation paths (that's up to you).  But they 
are nowhere on the system.

I assume these headers should in theory be installed by this RPM:
libstdc++-devel-2.96-69.i386.rpm

I am able to build the necessary headers by running
rpm -i gcc-2.96-69.src.rpm
rpm -bi gcc.spec

The necessary headers are generated, but they are not copied to the 
install directory, never packaged in any RPM, and never installed on the 
system.

I'm not sure if this bug has anything to do with bug #13618

Comment 1 Jakub Jelinek 2001-01-12 12:55:34 UTC
This is not a bug. We don't build libstdc++-v3 which only contains that header,
because at the time we stabilized gcc-2.96 (Jul 2000), libstdc++-v3 was nowhere
near to be ready. And at the moment we'd introduce binary incompatibility
with RHL 7.0 compiler. Please wait until gcc-3.0 is ready.


Note You need to log in before you can comment on or make changes to this bug.