Bug 23691 - up2date fails during update query
Summary: up2date fails during update query
Status: CLOSED DUPLICATE of bug 18994
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-10 04:50 UTC by Brian Harvell
Modified: 2007-04-18 16:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-10 04:50:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Harvell 2001-01-10 04:50:05 UTC
I get the following error while trying to run up2date. From references on
the web it sounds like helix gnome may be partly to blame.

tia[root][23:49][~]# up2date -l

Retrieving list of all available packages...

Removing installed packages from list of updates...
100.0%
Removing packages marked to skip from list...
100.0%
Getting headers for available packages...
100.0%
Removing packages with files marked to skip from list...
Traceback (innermost last):
  File "/usr/sbin/up2date", line 394, in ?
    main()
  File "/usr/sbin/up2date", line 377, in main
    sys.exit(batchRun(onlyList, pkgNames, fullUpdate))
  File "/usr/sbin/up2date", line 139, in batchRun
    updated, skipped = up2date.getUpdatedPackageList(printit, percent)
  File "/usr/share/rhn/up2date/up2date.py", line 897, in getUpdatedPackageList
    progressCallback)
  File "/usr/share/rhn/up2date/up2date.py", line 854, in
removeSkipFilesPackagesFromList
    if checkModified(h, f_i):
  File "/usr/share/rhn/up2date/up2date.py", line 773, in checkModified
    installedHdr = installedHeader(hdr['name'])
  File "/usr/share/rhn/up2date/up2date.py", line 162, in installedHeader
    for index in db.findbyname(pkgName):
rpm.error: error reading from database

Comment 1 Preston Brown 2001-02-09 05:29:07 UTC

*** This bug has been marked as a duplicate of 18994 ***


Note You need to log in before you can comment on or make changes to this bug.