Bug 236932 - Memory test on large mem systems may fail with undersized swap space
Memory test on large mem systems may fail with undersized swap space
Status: CLOSED DUPLICATE of bug 237556
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Greg Nichols
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-18 11:16 EDT by Rick Hester
Modified: 2008-07-16 17:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 10:03:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Hester 2007-04-18 11:16:17 EDT
Description of problem:
The memory cert test on a system with 192GB of memory failed apparently
due to the oom killer being invoked sometime during the test.   The
system had been installed with the default amount swap space which was
less than the amount of memory in the system.

I increased the swap space to greater than the amount of memory (in this
case it was about 1.5 times as much).   This resolved the oom killer 
problems and the test passed.

I would suggest that the hts documentation include a note about having
swap space greater than the amount of memory available.  (Or better yet
supply some formula for determining the minimum amount of swap required,
since it may not always require that much swap space.   For some systems
it will be a challenge to get that much swap.  The largest memory system
we have currently is 2TB and they are not getting smaller.)

Version-Release number of selected component (if applicable):
hts-5.0-32

How reproducible:

1/1
Steps to Reproduce:
1.Run the memory cert on a system with more memory than the default swap
2.
3.
  
Actual results:
oom killer causes test to fail

Expected results:
test to pass

Additional info:
Comment 1 Greg Nichols 2007-05-01 10:03:32 EDT

*** This bug has been marked as a duplicate of 237556 ***

Note You need to log in before you can comment on or make changes to this bug.