Bug 237556 - Documentation should be added for size of swap space when running memory test
Summary: Documentation should be added for size of swap space when running memory test
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact:
URL:
Whiteboard:
Keywords:
: 236932 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-23 19:14 UTC by Rick Hester
Modified: 2008-07-16 21:56 UTC (History)
0 users

Fixed In Version: RHBA-2007-0736
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-02 16:30:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0736 normal SHIPPED_LIVE hts bug fix available 2007-10-24 15:32:42 UTC

Description Rick Hester 2007-04-23 19:14:07 UTC
Description of problem:
I was running a memory cert test on a system with 192GB of memory and
started encountering the oom-killer.  This appears to result in cert
test failures.   

I noticed that the default swap space that I had used was less than the
amount of memory in the box.   I increased this swap space to about
1.5 - 2 times the amount of memory.  I was able to successfullly run
the memory cert test to completion with no failures.

The RHEL 5 cert documentation should include advice for sizing of swap space
when running the memory test.

It would also be beneficial if there are other known configuration requirements
for tests to succeed that they aslo be included in the documentation.

Version-Release number of selected component (if applicable):
hts-5.0-32

How reproducible:
1/1

Steps to Reproduce:
1. run memory cert test on system with less swap space than available memory
2.
3.
  
Actual results:
oom-killer results in failed test

Expected results:
no configuration-related failures

Additional info:

Comment 1 Greg Nichols 2007-05-01 13:52:10 UTC
The recommended swap space configuration for the memory 
test should would be that of a normal RHEL configuration, 
and should be covered by RHEL's documentation.

It does seem appropriate to alert the tester to this issue
in HTS docs, however.



Comment 2 Greg Nichols 2007-05-01 14:00:13 UTC
Added note, R45

Comment 3 Greg Nichols 2007-05-01 14:03:33 UTC
*** Bug 236932 has been marked as a duplicate of this bug. ***

Comment 6 Red Hat Bugzilla 2007-08-02 16:30:37 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0736.html



Note You need to log in before you can comment on or make changes to this bug.