Bug 237082 - post install scripts looks in wrong directory for dot
post install scripts looks in wrong directory for dot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: graphviz (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jima
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-19 08:05 EDT by Karsten Hopp
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.12-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 10:52:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2007-04-19 08:05:04 EDT
Description of problem:
ERROR: Output running post install script for package graphviz-0:2.12-6.fc7.i386
/var/tmp/rpm-tmp.VmJqcC: line 1: /bin/dot: No such file or directory

rpm -ql graphwiz shows that dot is in /usr/bin now

Version-Release number of selected component (if applicable):
graphviz-2.12-6.fc7.i386
Comment 1 Karsten Hopp 2007-04-19 10:36:24 EDT
The scriptlets look strange, variables didn't get expanded:
> rpm -qp --scripts graphviz-2.12-6.fc7.i386.rpm
warning: graphviz-2.12-6.fc7.i386.rpm: Header V3 DSA signature: NOKEY, key ID
1ac70ce6
postinstall scriptlet (using /bin/sh):
LD_LIBRARY_PATH=$RPM_INSTALL_PREFIX0/lib $RPM_INSTALL_PREFIX0/bin/dot -c
/sbin/ldconfig

# if there is no dot after everything else is done, the remove config
postuninstall scriptlet (using /bin/sh):
if ! test -x $RPM_INSTALL_PREFIX0/bin/dot; then rm -f
$RPM_INSTALL_PREFIX0/lib/graphviz/config; fi


Same error with the post script of graphviz-gd
Comment 2 John Ellson 2007-04-19 11:45:42 EDT
Sounds like relocatabilty has been turned off?    If the package is not
relocatable then RPM_INSTALL_PREFIX0 doesn't get set, which is arguable an rpm bug.
Comment 3 John Ellson 2007-04-19 12:06:08 EDT
Works for me using:

rpmbuild --rebuild graphviz-2.12-6.fc7.src.rpm

on fedora development, x86_64


Comment 4 Jima 2007-04-23 12:16:05 EDT
I'm synching my devel mirror up right now (it's out of synch due to hardware
failure, whee), but I'll be doing a test build in plague/mock.

I do recall this working in the past, but if it doesn't now, my best guess is
that I'm going to have to disable the relocatability.  It's a nice feature, but
not if it breaks normal functionality. :-(

I'm also looking at BZ#237496, which I admit I have no idea what to do with.
Comment 5 John Ellson 2007-04-23 12:45:52 EDT
It was turning off relocatability that caused the breakage, I think.

Enabling relocatability causes rpmbuild to set RPM_INSTALL_PREFIX0

Comment 6 Jima 2007-08-29 10:52:10 EDT
This bug was resolved (albeit in an unfortunate way) in 2.12-7; closing this bug.

Note You need to log in before you can comment on or make changes to this bug.