Bug 237137 - Package Request: thunderbird lightning plugin for calendar synchronization
Package Request: thunderbird lightning plugin for calendar synchronization
Status: CLOSED DUPLICATE of bug 357661
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
: 429339 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2007-04-19 13:03 EDT by Nurdin Premji
Modified: 2014-03-16 23:06 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-30 11:03:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Patch to enable building lightning together with thunderbird (5.36 KB, patch)
2007-10-29 08:55 EDT, David Fraser
no flags Details | Diff
Extra mozconfig file that includes the switch to enable building the extension (98 bytes, text/plain)
2007-10-29 08:56 EDT, David Fraser
no flags Details
The actual modified specfile to build thunderbird and lightning 0.7 (28.29 KB, text/plain)
2007-10-29 09:03 EDT, David Fraser
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 352543 None None None Never
Mozilla Foundation 381580 None None None Never

  None (edit)
Description Nurdin Premji 2007-04-19 13:03:37 EDT
Can the lightning plugin for thunderbird be packaged for fedora?

Comment 1 Levente Farkas 2007-06-06 09:45:12 EDT
I also vote for it!
Comment 2 Levente Farkas 2007-06-11 17:03:00 EDT
the main problem is twofold.
first of all a lightning addon build takes more then a kernel or gcc compile!
second fedora thunderbird compile configuration is different from the default
mozilla thunderbird config. which means the lightning plugin downloadable from
mozilla plugins download page:
is not working on fedora (which means it's installable but not working properly).

so it's very desirable to add lightning build to thunderbird.

anyway for those who'd like to use lightning on fedora 7, here is my version:
Comment 3 Russell Odom 2007-06-12 03:14:42 EDT
Levente, is there any chance that you could provide a build for x86_64 as well?
Comment 4 Christopher Aillon 2007-06-12 11:30:15 EDT
No thunderbird-devel package yet.  This might need to be F8 material.
Comment 5 Michael Cronenworth 2007-06-12 17:57:02 EDT
You can use the thunderbird extension from www.mozilla.com without any problem.
Do we really need a separate package for each extension? No need to custom
compile for Fedora.

Lightning Nightly Linux Builds:
Comment 6 Christopher Aillon 2007-06-12 18:12:37 EDT
Is it available for every arch we support?  Does it run against older versions
of e.g. glibc?
Comment 7 Russell Odom 2007-06-13 03:15:11 EDT
In short, no - Mozilla don't appear to build for x86_64. There was a
user-contributed x86_64 build for 0.3, but not for 0.3.1 (the current release)
and it didn't work on my system (FC6).
Comment 8 Christopher Aillon 2007-06-13 10:32:35 EDT
Then we probably do need a custom version.  Unfortunately, because of the gecko
story, we have no good way to do this right now.  This requires a major change
(XULRunner) which we will be doing for FC8.  I might be able to backport to FC7
and older depending on how well that goes.
Comment 9 Michael Cronenworth 2007-06-14 14:16:24 EDT
I've added two Mozilla bugs that would make this bug irrelevant. Wouldn't it be
more useful to help the Lightning team directly rather than package a custom RPM
for Fedora only?
Comment 10 Christopher Aillon 2007-06-14 17:00:26 EDT
There's no way to guarantee that the build will run on all current distros
equally well because of dependencies, filesystem structure, etc.
Comment 11 Michael Cronenworth 2007-06-15 15:06:13 EDT
Lightning doesn't require any special dependencies. As long as you have
Thunderbird installed -- it will work.
It doesn't require any special file structure.

This bug is just to get a 64-bit version of Lightning built because the
Lightning folks haven't done it. It's a typical user add-on for Thunderbird with
a small binary piece. Nothing more.
Comment 12 Christopher Aillon 2007-06-15 15:45:57 EDT
Link-time dependencies are still dependencies.  See for example Google Toolbar.
 It is just a small binary but doesn't work with Fedora 7 because it was built
against an old toolchain.  Building against a newer toolchain would mean that it
wouldn't work with older distros.
Comment 13 Jonathan Underwood 2007-06-21 13:04:34 EDT
This gets a vote from me, it is a real bind not being able to use lightning in F7.
Comment 14 Levente Farkas 2007-07-11 10:14:37 EDT
mike your comment is simple not true. have you ever try mozilla build of
lightning? they are _not_ working on neither fc6 nor f7. and if you read my
mozilla response to my mail they do not even plan a build which works for
fedora. anyway the latest 0.5 build for f7 can be found:
0.5 works well while 20070707 build contains the new layout but for me (with
large .ics files) this version is very slow.
Comment 15 Levente Farkas 2007-07-11 10:16:27 EDT
the best would be to add a subpackage to thunderbird and simple build along with
it. i can send a patch to the spec file:-)
Comment 16 David Fraser 2007-10-29 08:28:11 EDT
0.7 builds of lightning don't work on f7 either.

I have a patch to the thunderbird spec file to build lightning as well, which
I'm going to attach.

I would argue that lightning is a special case of an extension anyway, since the
default build instructions seem to require building the whole of thunderbird, so
this seems the best way to do it.
Comment 17 David Fraser 2007-10-29 08:55:21 EDT
Created attachment 241791 [details]
Patch to enable building lightning together with thunderbird

This is a patch to the thunderbird specfile to enable building lightning
together with thunderbird
I'll also attach the actual specfile and the thunderbird-mozconfig-lightning
file which simply adds the configuration file
Comment 18 David Fraser 2007-10-29 08:56:14 EDT
Created attachment 241801 [details]
Extra mozconfig file that includes the switch to enable building the extension
Comment 19 David Fraser 2007-10-29 09:03:42 EDT
Created attachment 241811 [details]
The actual modified specfile to build thunderbird and lightning 0.7

And here's the actual specfile.
RPMS here:
(the thunderbird rpms are basically unchanged but included for completeness -
these are still uploading as I submit this...)
SRPM here:
Mozilla doesn't release an actual source archive for Lightning, so I created
one from cvs as described in the specfile, available here:
Comment 20 David Fraser 2007-10-29 09:11:56 EDT
Any comments on the above appreciated - should I ask for review?
Comment 21 David Fraser 2007-10-31 04:04:58 EDT
Some relevant links on the default Lightning not working with Fedora:
Comment 22 David Fraser 2007-10-31 05:01:41 EDT
Added request for review on patch
Comment 23 Matěj Cepl 2007-10-31 05:42:21 EDT
I think, that currently this being not full blown package review should fit more
into component "distribution".
Comment 24 David Fraser 2008-01-04 04:49:09 EST
Do I need to re-request review on this patch after it being moved between
Comment 25 Christopher Aillon 2008-01-04 09:41:38 EST
We are not going to build extensions from within the thunderbird SRPM.

I'm working on fixing how we do extensions, but right now, there's no good way
to do this.
Comment 26 David Fraser 2008-01-07 16:41:02 EST
Re Comment 25:

I sure agree that we shouldn't build extensions in general from the thunderbird
SRPM. Lightning is different because:
A) It's in the Mozilla codebase
B) It's one of the few official extensions produced by Mozilla
C) There are key reasons it's built like this (it's essentially a part of
thunderbird that's stripped from the default build)

I can understand though if you don't want to do this. But would it be acceptable
then to make a separate SRPM for lightning that includes the thunderbird source
code, builds thunderbird and lightning, and discards the thunderbird build?

Otherwise it's pretty much making it impossible for Fedora users to have a
decent lightning install
Comment 27 Christopher Aillon 2008-01-07 17:46:32 EST
Believe me, I understand how lightning is not your average extension, but it's
still an extension.  The distributor is a little irrelevant here to the reasons
why we can't take it like this.

I don't think it's feasible either to essentially duplicate the thunderbird
source tree in a different SRPM because:

* A system installed extension in the current way of doing things would have to
reside within the thunderbird application directory, which changes with each new
version currently ($LIBDIR/thunderbird-$version).  This means there would be RPM
conflicts if both aren't upgraded simultaneously, or you would lose the
extension on upgrades.
* It is an additional burden to sync two trees up identically.  Every time I
patch our thunderbird RPM, lightning really should get the same patch, and vice
versa to keep things in optimal sync, especially on these versions where there
isn't a guaranteed stable API.
* It is extra work for releasing security updates which are not infrequent,
especially because of the two above items.

I promise you I'm working on the code to do this the correct way.  I attached
the patch upstream yesterday in fact, and so far has received positive comments,
so it should be accepted soon I hope.  I'm pushing hard for it.  The only
drawback is I'm not sure how doable it would be to port it to FC8 or 7.  It
might have to be an FC9+ thing... But I'll see what I can do.

Comment 28 David Fraser 2008-01-09 03:07:01 EST
OK, presume you're talking about
https://bugzilla.mozilla.org/show_bug.cgi?id=311008 - that looks great.

All the specific lightning issues still remain though - unless we make it
possible to build lightning entirely independently of thunderbird, which still
doesn't necessarily mean we'll avoid any need for version updates.

So given your points in Comment 27, do you have a proposal for how this should
be done?
Comment 29 Christopher Aillon 2008-01-09 03:30:40 EST
Making it build independently is not a difficult problem to solve, but it
doesn't do any good if there's no place to stick it.  That's why 311008 is so
Comment 30 Matěj Cepl 2008-02-28 09:41:13 EST
*** Bug 429339 has been marked as a duplicate of this bug. ***
Comment 32 David Fraser 2008-03-24 00:49:19 EDT
(In reply to comment #29)
> Making it build independently is not a difficult problem to solve, but it
> doesn't do any good if there's no place to stick it.  That's why 311008 is so
> important.

Just a note that https://bugzilla.mozilla.org/show_bug.cgi?id=311008 has been
checked in (but presumably we need to wait for this to percolate up to the
current branch)
Comment 33 Felix Schwarz 2008-03-30 10:54:29 EDT
Sorry für the noise but isn't this bug a duplicate of #357661? The sunbird
package in EPEL5 does already include thunderbird-lightning
Comment 34 Lubomir Kundrak 2008-03-30 11:03:07 EDT
Building and will push the package shortly

*** This bug has been marked as a duplicate of 357661 ***

Note You need to log in before you can comment on or make changes to this bug.