Bug 429339 - Thunderbird 2.0.0.9 fc8 binary incompatible with add-ons
Thunderbird 2.0.0.9 fc8 binary incompatible with add-ons
Status: CLOSED DUPLICATE of bug 237137
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
: 245510 315111 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-18 14:54 EST by Kai Engert (:kaie)
Modified: 2008-02-28 09:41 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 09:41:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kai Engert (:kaie) 2008-01-18 14:54:33 EST
I upgraded from fc7 to fc8, keeping /home
I installed thunderbird-2.0.0.9.fc8.i386
I installed the lightining 0.7 calendar addon

With that configuration, thunderbird looks "wrong".
There is an unexpected calendar pane on the left hand side.
The right hand side is "empty", you might call it even "distorted".
No information from my subscribed calendars is shown.

I suspect this is due to some binary INcompatibility.

I uninstalled the add-on from my profile.
I downloaded an official thunderbird 2.0.0.9 binary from ftp.mozilla.org
I started the mozilla.org thundebird and re-installed the add-on.

Now everything works as expected!
Comment 1 Kai Engert (:kaie) 2008-01-18 14:58:36 EST
Interesting:

The compatibility might only be related to installation-time.

After I have used the official binary to install, I am able to run
thunderbird.fc8 and it works, too.
Comment 2 Kai Engert (:kaie) 2008-01-18 15:04:11 EST
Ok, I understand now.

The lightning add-on comes with binaries.
Those binaries require old libstdc++.so.5

My system did not have that library when I first tried to run it.
So, I did not get any error messages on the console, all I got was the distorted UI.

When I tried to execute the thunderbird binary from mozilla.org, I noticed
libstdc++.so.5 is missing and installed compat-libstdc++

Once I had that library, the lightning plugin worked.
Comment 3 Matěj Cepl 2008-01-18 18:05:41 EST
Don't know what to think about the idea to make thunderbird dependent on
compat-libstdc++. Caillon?
Comment 4 Kai Engert (:kaie) 2008-01-19 06:47:29 EST
This bug should be extended to other Mozilla software as well.

For example, the Google toolbar extension for Firefox includes .so files, too,
and they require to the same old libstdc++.so.5

(While basic functionality of that extension seems to work with our firefox, I'm
sure there is some advanced functionality that won't work.)
Comment 5 Kai Engert (:kaie) 2008-01-19 06:56:21 EST
I found another Linux extension, html-tidy, and it's indeed broken.
I even have a completely broken url-bar (always empty).

http://users.skynet.be/mgueury/mozilla/download.html
http://htmlvalidator.sourceforge.net/mozilla/tidy_firefox_linux_0843.xpi
http://users.skynet.be/mgueury/mozilla/faq.html#LINUX
Comment 6 Kai Engert (:kaie) 2008-01-20 18:35:36 EST
If I understand correctly, it's considered unsafe to mix different versions of
c++ libraries in a process (risk of mixing alloc/free from different libs).
Comment 7 Matěj Cepl 2008-02-28 09:37:46 EST
*** Bug 315111 has been marked as a duplicate of this bug. ***
Comment 8 Matěj Cepl 2008-02-28 09:37:58 EST
*** Bug 245510 has been marked as a duplicate of this bug. ***
Comment 9 Matěj Cepl 2008-02-28 09:41:12 EST

*** This bug has been marked as a duplicate of 237137 ***

Note You need to log in before you can comment on or make changes to this bug.