Bug 237206 - Clicking ok on bad cert crashes (see 220714)
Summary: Clicking ok on bad cert crashes (see 220714)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-04-19 23:29 UTC by Trever Adams
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-20 23:17:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Trace back for problem (19.08 KB, text/plain)
2007-05-06 13:25 UTC, Trever Adams
no flags Details

Description Trever Adams 2007-04-19 23:29:36 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Every time evolution starts

Steps to Reproduce:
1. Connect to a pop server with a self signed cert (may require to accounts on
the same server)
2. Click ok on both dialogs
3. CRASH
  
Actual results:
It crashes of course.

Expected results:
It shouldn't crash.

Comment 1 Matthew Barnes 2007-04-20 01:04:37 UTC
What version-release number are you using?

Comment 2 Trever Adams 2007-04-20 21:06:46 UTC
I was afraid I had forgoten that. evolution-2.10.1-4.fc7.

Comment 3 Trever Adams 2007-05-06 13:25:44 UTC
Created attachment 154226 [details]
Trace back for problem

Comment 4 Andrew Overholt 2007-05-15 19:46:22 UTC
I'm hitting the same problem now.

Comment 5 Matthew Barnes 2007-05-15 20:34:50 UTC
I'm seeing a deadlock, not a crash.  The traceback doesn't show a crash either.

Comment 6 Andrew Overholt 2007-05-15 20:35:46 UTC
Yeah, I'm seeing a deadlock as well.

Comment 7 Trever Adams 2007-05-15 20:39:13 UTC
Whatever it is, bugbuddy came up. It stalls (hangs) for about 1 minute before
bug buddy shows up for me.

Comment 8 Matthew Barnes 2007-05-15 21:02:39 UTC
Ah, maybe I wasn't waiting long enough then.

Comment 9 Andrew Overholt 2007-05-15 21:16:34 UTC
Bugbuddy never came up for me.  I waited for a long time.

Comment 10 Matthew Barnes 2007-05-16 21:20:37 UTC
Should be fixed in evolution-2.10.1-17.fc7.

This turned out to be another game of "who owns the message and when should it
be freed?", just like bug #220714 and others like it were.  I've had a patch
waiting in the wings for some time that makes Evolution's message passing use
reference counting to track ownership of the messages, rather than the
convoluted logic that's there now.

The patch fixes the crash but it's a bit experimental.  If you guys could help
me test this over the next few days I'd appreciate it, since we're in the final
stretch for Fedora 7 now and I'm a bit nervous about putting this in at the 11th
hour.

Please post comments here if you see any regressions that you think might be
related to this.

Comment 11 Andrew Overholt 2007-05-17 14:53:56 UTC
This build fixes the bad cert issue for me.  I'll continue using it and see if I
notice any other problems.  Thanks!

Comment 12 Will Woods 2007-05-19 17:45:28 UTC
Can you confirm that this is fixed with the updated evolution package Matthew
mentioned, available here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=6684


Comment 13 Trever Adams 2007-05-20 23:11:21 UTC
I have changed my email accounts in such a way that I no longer see the bug. (It
was only hitting if I had two accounts on the same server or two servers with
bad certs... I no longer have that.)

I am sorry I cannot test further. If others say it fixes the problem, then that
is good enough I guess.

Comment 14 Matthew Barnes 2007-05-20 23:17:41 UTC
Closing based on comment #11 and my own testing.

Feel free to reopen this bug if you encounter these crashes again.


Note You need to log in before you can comment on or make changes to this bug.