Bug 237327 - gnome-power-statistics crashes after a minute or so running
gnome-power-statistics crashes after a minute or so running
Status: CLOSED DUPLICATE of bug 239228
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-20 16:11 EDT by Jarod Wilson
Modified: 2013-03-05 22:49 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-07 20:26:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
g-p-s trace captured by bugbuddy (7.50 KB, text/plain)
2007-04-23 09:53 EDT, Jarod Wilson
no flags Details
another bug buddy stack trace (7.97 KB, text/plain)
2007-04-28 09:12 EDT, David Timms
no flags Details
bugtrace under vmware (x86) with gnome-power-manager-debuginfo (5.46 KB, text/plain)
2007-05-04 17:48 EDT, Yi Ding
no flags Details

  None (edit)
Description Jarod Wilson 2007-04-20 16:11:55 EDT
Description of problem:
If I run gnome-power-statistics on either my Dell Precision 490 workstation
(x86_64 install on hard drive) or a Dell PowerEdge 840 (booted off i386 live
media), it crashes within a minute or so of running, launching bug buddy.

Version-Release number of selected component (if applicable):
gnome-power-manager-2.18.2-1.fc7

How reproducible:
Just run it!
Comment 1 Matthias Clasen 2007-04-21 11:02:41 EDT
It doesn't do that here, can you perhaps attach the stack trace that bug-buddy
is capturing ?
Comment 2 Jarod Wilson 2007-04-23 09:53:53 EDT
Created attachment 153282 [details]
g-p-s trace captured by bugbuddy

Here's the stack trace that bug buddy captures.
Comment 3 David Timms 2007-04-28 09:12:55 EDT
Created attachment 153708 [details]
another bug buddy stack trace

Repeatable, around 17 seconds between start and crash.
machine history:
dell poweredge 1600sc, fc6, fc6 updates, f7test4 upgrade.
user profile is from fc6, ie not created with f7t4.
dual xeon cpus. ie 686 kernel.
Apr 28 18:33:03 poweredge kernel: Linux version 2.6.20-1.3104.fc7
(brewbuilder@hs20-bc1-6.build.redhat.com) (gcc version 4.1.2 20070418 (Red Hat
4.1.2-10)) #1 SMP Sat Apr 21 22:20:43 EDT 2007

main difference is reference to /lib rather than /lib64, and much longer
addresses referenced in the trace.
Comment 4 Yi Ding 2007-05-04 17:48:03 EDT
Created attachment 154177 [details]
bugtrace under vmware (x86) with gnome-power-manager-debuginfo

I'm getting the same problem under VMWare fusion.  I've attached the bugtrace.
Comment 5 Will Woods 2007-05-07 00:46:06 EDT
Think this might be a dupe of bug #239228 - can you try 2.18.2-3.fc7 from here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=6318
and see if that fixes it?
Comment 6 Matthias Clasen 2007-05-07 20:26:47 EDT
Same stacktrace, so yes, pretty sure this is a dupe.

*** This bug has been marked as a duplicate of 239228 ***
Comment 7 Richard Hughes 2007-05-11 12:16:53 EDT
I think I've fixed this on the 2-18 branch - I'll release 2.18.3 in a couple of
days and then we can push this to updates.

Note You need to log in before you can comment on or make changes to this bug.