Bug 237447 - WPA Enterprise stopped working
WPA Enterprise stopped working
Status: CLOSED DUPLICATE of bug 243590
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Christopher Aillon
Depends On:
  Show dependency treegraph
Reported: 2007-04-23 05:54 EDT by Matt Bernstein
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-06-22 06:02:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Matt Bernstein 2007-04-23 05:54:02 EDT
Description of problem:

can't connect to WPA Enterprise SSID any more

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. choose a WPA Enterprise SSID
2. fill in your authentication credentials
3. look in your .xsession-errors for "nmi_save_network_info(): Error saving
secret for wireless network 'dcs_wpa' in keyring: 5"
Actual results:

not on the WPA Enterprise SSID

Expected results:

on the WPA Enterprise SSID

Additional info:

rolling back to f7test3 (0.6.5-0.4.svn2474.fc7) appears to fix it for me, so I
suspect it's a recent regression.
Comment 1 Matt Bernstein 2007-05-14 13:32:38 EDT
upping severity (a) to see if anyone notices (there's been no response for three
weeks now, mind you that's not unusual--see bug 209496) and (b) because I don't
want to see F7 broken in this respect as it will generate support load
Comment 2 James 2007-06-14 06:24:44 EDT
Hello, I suspect my Bug 243590 is a duplicate of this (I also got the impression
NM was having trouble storing the key). I'll try rolling back to the package you
suggested and see if this works for me.
Comment 3 Matt Bernstein 2007-06-22 06:02:21 EDT
Yes, I think you might be right.

NM does have trouble storing the key, but since you're offered the key during
the EAP conversation, it shouldn't need to store the key in the first place.

In fact it's worse than that, as it gives you the false sense of security that
your 802.1X password is being safely stored in the keyring, when actually NM
stores it in plain text in gconf.

Apparently NM 0.7 will fix this horrendous error. It's not due till after the
release of F8.

*** This bug has been marked as a duplicate of 243590 ***

Note You need to log in before you can comment on or make changes to this bug.