Bug 243590 - NM will only connect once to WPA-Enterprise network
Summary: NM will only connect once to WPA-Enterprise network
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
: 237447 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-10 09:32 UTC by James Ettle
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: NetworkManager-0.6.5-5.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-16 10:49:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Ettle 2007-06-10 09:32:01 UTC
Description of problem:
NetworkManager will only connect once to my WPA-Enterprise network. It presents
me the network form, on which I enter the authentication method, password and
certificate files and it then connects properly. But on all subsequent
connections, it fails (see log excerpt below) and I have to clean out the
contents of /system/networking/wireless/networks in gconf and restart nm-applet.

Usually I'd expect to be presented with a dialog prompting me to unlock the
keyring for the certificate password, but I'm not. I've checked with
gnome-keyring-manager that the relevant key is present and that nm-applet can
access it.

Version-Release number of selected component (if applicable):
NetworkManager-0.6.5-3.fc7
gnome-keyring-0.8-1.fc7
ipw2200 driver

How reproducible:
Always.

Steps to Reproduce:
1. Clean out network info in gconf tree.
2. Connect to WPA-Enterprise network.
3. Disconnect.
4. Attempt to reconnect.
  
Actual results:
Connection fails.

Expected results:
Clean connection.

Additional info:
I get lots of log messages like

Jun 10 10:27:11 harmony NetworkManager: <info>  Activation (eth1) New wireless
user key for network '<ESSID>' received. 
Jun 10 10:27:11 harmony NetworkManager: <info>  Activation (eth1) Stage 1 of 5
(Device Prepare) scheduled... 
Jun 10 10:27:11 harmony NetworkManager: <info>  Activation (eth1) Stage 1 of 5
(Device Prepare) started... 
Jun 10 10:27:11 harmony NetworkManager: <info>  Activation (eth1) Stage 2 of 5
(Device Configure) scheduled... 
Jun 10 10:27:11 harmony NetworkManager: <info>  Activation (eth1) Stage 1 of 5
(Device Prepare) complete. 
Jun 10 10:27:11 harmony NetworkManager: <info>  Activation (eth1) Stage 2 of 5
(Device Configure) starting... 
Jun 10 10:27:11 harmony NetworkManager: <info>  Activation (eth1/wireless):
access point '<ESSID>' is encrypted, but NO valid key exists.  New key needed. 
Jun 10 10:27:11 harmony NetworkManager: <info>  Activation (eth1) New wireless
user key requested for network '<ESSID>'. 
Jun 10 10:27:11 harmony NetworkManager: <info>  Activation (eth1) Stage 2 of 5
(Device Configure) complete. 
Jun 10 10:27:11 harmony NetworkManager: <info>  Activation (eth1) New wireless
user key for network '<ESSID>' received. 
Jun 10 10:27:11 harmony NetworkManager: <info>  Activation (eth1) Stage 1 of 5
(Device Prepare) scheduled... 
Jun 10 10:27:11 harmony NetworkManager: <info>  Activation (eth1) Stage 1 of 5
(Device Prepare) started... 
Jun 10 10:27:11 harmony NetworkManager: <info>  Activation (eth1) Stage 2 of 5
(Device Configure) scheduled... 
Jun 10 10:27:11 harmony NetworkManager: <info>  Activation (eth1) Stage 1 of 5
(Device Prepare) complete. 
Jun 10 10:27:11 harmony NetworkManager: <info>  Activation (eth1) Stage 2 of 5
(Device Configure) starting... 
Jun 10 10:27:11 harmony NetworkManager: <info>  Activation (eth1/wireless):
access point '<ESSID>' is encrypted, but NO valid key exists.  New key needed. 
Jun 10 10:27:11 harmony NetworkManager: <info>  Activation (eth1) New wireless
user key requested for network '<ESSID>'. 

and that's as far as it gets.
Jun 10 10:27:11 harmony NetworkManager: <info>  Activation (eth1) Stage 2 of 5
(Device Configure) complete.

Comment 1 James Ettle 2007-06-16 10:49:24 UTC
Closing, appears to be fixed by update.

Comment 2 Matt Bernstein 2007-06-22 10:02:28 UTC
*** Bug 237447 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.