This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 237666 - upgrade form fc6 does not complete
upgrade form fc6 does not complete
Status: CLOSED DUPLICATE of bug 238256
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-24 12:35 EDT by Gianluca Cecchi
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 17:04:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upgrade.log file (54.53 KB, text/plain)
2007-04-24 12:36 EDT, Gianluca Cecchi
no flags Details
upgrade.log.syslog file (954 bytes, text/plain)
2007-04-24 12:37 EDT, Gianluca Cecchi
no flags Details
anaconda.log file (15.41 KB, text/plain)
2007-04-24 12:37 EDT, Gianluca Cecchi
no flags Details
output of dmesg before ctrl+alt+canc (16.00 KB, text/plain)
2007-04-24 12:38 EDT, Gianluca Cecchi
no flags Details
yum.log file after reboot and upgrade proposed by puplet (8.27 KB, text/plain)
2007-04-24 13:04 EDT, Gianluca Cecchi
no flags Details

  None (edit)
Description Gianluca Cecchi 2007-04-24 12:35:19 EDT
Description of problem:
gui remains at display with 1192 of 1192 packages installed
after ctrl+alt+can apparently all is ok, also grub update, but upgrade itself
does not complete

Version-Release number of selected component (if applicable):
anaconda-11.2.0.54-2.x86_64.rpm

How reproducible:
not reproducible: system was upgraded.
installation was from physical dvd. 

Steps to Reproduce:
1.
2.
3.
  
Actual results:
gui remains at display with 1192 of 1192 packages installed

Expected results:
final messages with option to reboot

Additional info:
running dmesg inside system before ctrl+alt+canc  I get at the end
<6>EXT3-fs: mounted filesystem with ordered data mode.
<7>SELinux: initialized (dev sda3, type ext3), uses xattr
<6>Adding 522072k swap on /dev/sda5.  Priority:-1 extents:1 across:522072k
<7>security:  3 users, 6 roles, 1798 types, 76 bools, 1 sens, 1024 cats
<7>security:  60 classes, 64845 rules
<6>redhat_lsb_trig[13411]: segfault at 0000000000000028 rip 00000000004002a4 rsp
00007fff115eec20 error 4
<6>redhat_lsb_trig[13414]: segfault at 0000000000000028 rip 00000000004002a4 rsp
00007fff04f0ba40 error 4


In upgrade.log I get:
Upgrading xorg-x11-drv-rendition - 4.1.3-2.fc7.x86_64
Upgrading xorg-x11-drv-tseng - 1.1.0-5.fc7.x86_64
Upgrading xorg-x11-drv-ark - 0.6.0-3.fc7.x86_64
Upgrading xorg-x11-drivers - 7.2-5.fc7.x86_64
/var/tmp/rpm-tmp.8860: line 3: 13411 Segmentation fault     
/usr/sbin/redhat_lsb_trigger.x86_64
/var/tmp/rpm-tmp.83702: line 3: 13414 Segmentation fault     
/usr/sbin/redhat_lsb_trigger.x86_64
/var/tmp/rpm-tmp.25697: line 3: 13802 Segmentation fault     
/usr/sbin/redhat_lsb_trigger.x86_64
/var/tmp/rpm-tmp.25697: line 3: 13805 Segmentation fault     
/usr/sbin/redhat_lsb_trigger.x86_64
error: %postun(gnome-panel-2.16.3-2.fc6.i386) scriptlet failed, signal 15

in upgrade.log.syslog I get
08:23:27 INFO    : switching from CD [1] to 1 for 
08:23:38 INFO    : moving (1) to step postselection
08:23:38 DEBUG   : no kernel-smp package
08:23:38 INFO    : selected kernel package for kernel
08:37:00 INFO    : moving (1) to step confirmupgrade
08:37:40 INFO    : moving (1) to step install
08:37:45 INFO    : moving (1) to step migratefilesystems
08:37:45 INFO    : moving (1) to step preinstallconfig
08:37:52 DEBUG   : isys.py:mount()- going to mount /selinux on /mnt/sysimage/selinux
08:37:52 WARNING : no dev package, going to bind mount /dev
08:37:52 DEBUG   : isys.py:mount()- going to mount /dev on /mnt/sysimage/dev
08:37:52 INFO    : moving (1) to step installpackages
08:37:52 INFO    : Preparing to install packages

I'm going to attache whole files, too.
PC is a Dell Optiplex SX280
Comment 1 Gianluca Cecchi 2007-04-24 12:36:27 EDT
Created attachment 153360 [details]
upgrade.log file
Comment 2 Gianluca Cecchi 2007-04-24 12:37:08 EDT
Created attachment 153361 [details]
upgrade.log.syslog file
Comment 3 Gianluca Cecchi 2007-04-24 12:37:39 EDT
Created attachment 153362 [details]
anaconda.log file
Comment 4 Gianluca Cecchi 2007-04-24 12:38:57 EDT
Created attachment 153363 [details]
output of dmesg before ctrl+alt+canc
Comment 5 Gianluca Cecchi 2007-04-24 13:02:58 EDT
When rebooted the system made update of many packages (livna repository one +
wine and others)
lspci of this system is
[root@pevit00 ~]# lspci
00:00.0 Host bridge: Intel Corporation 82915G/P/GV/GL/PL/910GL Memory Controller
Hub (rev 04)
00:01.0 PCI bridge: Intel Corporation 82915G/P/GV/GL/PL/910GL PCI Express Root
Port (rev 04)
00:02.0 VGA compatible controller: Intel Corporation 82915G/GV/910GL Integrated
Graphics Controller (rev 04)
00:02.1 Display controller: Intel Corporation 82915G Integrated Graphics
Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 1 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW
(ICH6 Family) AC'97 Audio Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FB/FR (ICH6/ICH6R) LPC Interface
Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE
Controller (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FB/FW (ICH6/ICH6W) SATA Controller
(rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus
Controller (rev 03)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit
Ethernet PCI Express (rev 01)

I'm going to attach yum.log of packages updated after reboot.


Comment 6 Gianluca Cecchi 2007-04-24 13:04:19 EDT
Created attachment 153367 [details]
yum.log file after reboot and upgrade proposed by puplet
Comment 7 Gianluca Cecchi 2007-04-27 03:55:47 EDT
I did the same x86_64 upgrade on another more powerful PC (quad core with sata
300 hd).
I used the final test4 rsynced tree bumped to a dvd.
Apparently it happened the same thing after arriving to the step

1210 of 1210 packages installed

But as the hd of this pc is quite noisy, I understood that actually the system
was writing to disk.... not stalled. 
Infact a vmstat on a virtual console showed that I had about 4MB/s of write
activity.... at the end, I think after about 15 minutes, the final screen with
the message to reboot appeared....
So it seems this is not a bug.
But probably it would be smart, if possible, to put an intermediate screen
telling that final activities are in place....
I don't know if it is a cleanup phase or an overall commit phase, but I think
that on slower machines it could last too much if without messages...
I leave open the bug to get your comments about this.
Thanks, gianluca
 
Comment 8 Gianluca Cecchi 2007-05-01 17:04:32 EDT
I opened this bug before # 238256 but I think they are the same so I close it,
because the former is resolved in anaconda-11.2.0.57-1.


*** This bug has been marked as a duplicate of 238256 ***

Note You need to log in before you can comment on or make changes to this bug.