Bug 238256 - UI: upgrade appears to be stalled at completion for 13 minutes.
Summary: UI: upgrade appears to be stalled at completion for 13 minutes.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
: 237666 (view as bug list)
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-04-28 11:42 UTC by David Timms
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-30 22:41:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Timms 2007-04-28 11:42:59 UTC
Description of problem:
When upgrading, the UI shows say 700/700 packages complete, and then statys that
way for more than 13 minutes. To non-tech user, this appears to be a crash or
hang, and they may press reboot / power off to fix the "crash". Hour-glass mouse
cursor is not enough !

Version-Release number of selected component (if applicable):
fc6 {up2date 2007-04-20} -> f7test4 pxeboot+ftp

How reproducible:
l8r

Steps to Reproduce:
1. upgrade
2. package 700/700 completes
  
Actual results:
bar graph is a few pixels from complete, the mouse activity thingy is spinning
but it seems like nothing is happening for a long time.
Eventually the "congratulations the installation is complete" message is shown,
as expected.

Expected results:
Adjust the UI to consider the total number of transactions to be done, and
divide the progress bar into this number of parts.

Even better: show the expected time until completion {over estimate rather than
under estimate}.
Better again: "Fedora will be ready to serve you in: 6min 45 seconds".
The maximum time between status updates should be low eg 1 second.

Additional info:
As I understand it, the progress bar shows progress through the package
installs, but not the package removes that are required in an upgrade; these
actually take some time to complete.

Comment 1 Jeremy Katz 2007-04-30 19:01:20 UTC
We're not taking into account cleanups with the progress display; we should
really fix this for F7

Comment 2 Jeremy Katz 2007-04-30 22:41:37 UTC
Integrating into the progress bar is going to be a little disruptive, but fixed
so we at least pop up something up to say that it may be a little bit

Comment 3 Gianluca Cecchi 2007-05-01 21:04:45 UTC
*** Bug 237666 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.