Bug 237736 - system-config-date crashes
Summary: system-config-date crashes
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-date   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 237777
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-25 03:54 UTC by Arthur Pemberton
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 12:45:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Arthur Pemberton 2007-04-25 03:54:42 UTC
Description of problem:
system-config-date crashes when there is not ntp server list

Version-Release number of selected component (if applicable):
system-config-date-1.8.8-1.fc6

How reproducible: I have only been able to try this on one machine so far


Steps to Reproduce:
1. install Fedora 6
2. do not setup ntp servers
3. run system-config-date (from a console)
  
Actual results:
program crashes due to programming error

Expected results:
program starts up and allows me to configure ntp

Additional info:

* problem stems from getNtpServers() in dateBackend.py, it fails to return a
tuple if self.ntpFile evaluates to False

Comment 1 Nils Philippsen 2007-04-25 12:45:24 UTC
This issue should be fixed in 1.8.12-2.fc6 which should hit mirrors soon.

Comment 2 Fedora Update System 2007-04-27 05:51:57 UTC
system-config-date-1.8.12-2.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.