Bug 237777 - system-config-date crashes
system-config-date crashes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks: 237736
  Show dependency treegraph
 
Reported: 2007-04-25 08:15 EDT by Nils Philippsen
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 08:37:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2007-04-25 08:15:43 EDT
+++ This bug was initially created as a clone of Bug #237736 +++

Description of problem:
system-config-date crashes when there is not ntp server list

Version-Release number of selected component (if applicable):
system-config-date-1.8.8-1.fc6

How reproducible: I have only been able to try this on one machine so far


Steps to Reproduce:
1. install Fedora 6
2. do not setup ntp servers
3. run system-config-date (from a console)
  
Actual results:
program crashes due to programming error

Expected results:
program starts up and allows me to configure ntp

Additional info:

* problem stems from getNtpServers() in dateBackend.py, it fails to return a
tuple if self.ntpFile evaluates to False
Comment 1 Nils Philippsen 2007-04-25 08:37:42 EDT
fixed in system-config-date-1.8.96

Note You need to log in before you can comment on or make changes to this bug.