Bug 237753 - Wrong init script
Wrong init script
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: acpid (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jiri Skala
:
: 237770 (view as bug list)
Depends On: 237752
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-25 05:02 EDT by Michal Marciniszyn
Modified: 2014-11-09 17:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-23 04:47:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Marciniszyn 2007-04-25 05:02:03 EDT
+++ This bug was initially created as a clone of Bug #237752 +++

Description of problem:
This construction returns error code 0 even when the service is not correctly
runned:

[ -x /usr/sbin/acpid ] || exit 0
[ -f /proc/acpi/event ] || exit 0

Also the status command (that should always return state of the service) is
ended withou even finding out the state.

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1. rename conf file/change permissions on binary
2. service acpid start
3. echo $?
  
Actual results:
0

Expected results:
correct error code

Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is implemented correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html
Comment 1 Phil Knirsch 2007-05-16 11:54:22 EDT
So what would you suggest how to fix it? We can't really run the initscript
without kernel support. And letting it always fail with an error if the kernel
doesn't support ACPI isn't really good either.

Read ya, Phil
Comment 2 Zdenek Prikryl 2007-07-25 08:44:21 EDT
Init script is fixed in devel.
Comment 3 Zdenek Prikryl 2007-07-26 10:42:58 EDT
*** Bug 237770 has been marked as a duplicate of this bug. ***
Comment 4 RHEL Product and Program Management 2008-02-01 14:08:33 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Note You need to log in before you can comment on or make changes to this bug.