Bug 237752 - Wrong init script
Wrong init script
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: acpid (Show other bugs)
5.0
All Linux
medium Severity medium
: beta
: ---
Assigned To: Zdenek Prikryl
:
: 232153 (view as bug list)
Depends On:
Blocks: 237789 237753 237754
  Show dependency treegraph
 
Reported: 2007-04-25 04:56 EDT by Michal Marciniszyn
Modified: 2014-02-10 18:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:53:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Marciniszyn 2007-04-25 04:56:10 EDT
Description of problem:
This construction returns error code 0 even when the service is not correctly
runned:

[ -x /usr/sbin/acpid ] || exit 0
[ -f /proc/acpi/event ] || exit 0

Also the status command (that should always return state of the service) is
ended withou even finding out the state.

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1. rename conf file/change permissions on binary
2. service acpid start
3. echo $?
  
Actual results:
0

Expected results:
correct error code

Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is implemented correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html
Comment 1 Phil Knirsch 2007-05-16 11:54:15 EDT
So what would you suggest how to fix it? We can't really run the initscript
without kernel support. And letting it always fail with an error if the kernel
doesn't support ACPI isn't really good either.

Read ya, Phil
Comment 2 Zdenek Prikryl 2007-07-25 08:38:34 EDT
Init script is fixed in devel.
Comment 3 Zdenek Prikryl 2007-07-26 10:30:06 EDT
*** Bug 232153 has been marked as a duplicate of this bug. ***
Comment 4 RHEL Product and Program Management 2007-12-03 15:42:10 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 5 Denise Dumas 2008-07-11 15:09:47 EDT
Unless this moves to 5.4 by Tuesday, the bugbot is going to automatically close
it. Please either either get dev and qa acks for FastTrack or move to 5.4 before
that time. 
Comment 10 errata-xmlrpc 2009-01-20 15:53:49 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0091.html

Note You need to log in before you can comment on or make changes to this bug.