Bug 237754 - Wrong init script
Wrong init script
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: acpid (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Zdenek Prikryl
:
: 246860 (view as bug list)
Depends On: 237752
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-25 05:03 EDT by Michal Marciniszyn
Modified: 2014-02-10 18:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-25 05:06:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Marciniszyn 2007-04-25 05:03:34 EDT
+++ This bug was initially created as a clone of Bug #237752 +++

Description of problem:
This construction returns error code 0 even when the service is not correctly
runned:

[ -x /usr/sbin/acpid ] || exit 0
[ -f /proc/acpi/event ] || exit 0

Also the status command (that should always return state of the service) is
ended withou even finding out the state.

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1. rename conf file/change permissions on binary
2. service acpid start
3. echo $?
  
Actual results:
0

Expected results:
correct error code

Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is implemented correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html
Comment 1 Phil Knirsch 2007-05-16 11:54:32 EDT
So what would you suggest how to fix it? We can't really run the initscript
without kernel support. And letting it always fail with an error if the kernel
doesn't support ACPI isn't really good either.

Read ya, Phil
Comment 2 Zdenek Prikryl 2007-07-25 05:16:29 EDT
*** Bug 246860 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.