This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 237756 - Wrong init script
Wrong init script
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: am-utils (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Kent
qe-baseos-daemons
:
: 237757 237758 (view as bug list)
Depends On:
Blocks: 237789 928849
  Show dependency treegraph
 
Reported: 2007-04-25 05:21 EDT by Michal Marciniszyn
Modified: 2014-02-10 18:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-09 14:27:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Marciniszyn 2007-04-25 05:21:05 EDT
Description of problem:
Init script does not return correct error codes and has wrong status implementation.

Version-Release number of selected component (if applicable):
All

How reproducible:
Always

Steps to Reproduce:
1. rename conf file (/etc/amd.conf)
2. service amd start / service amd status
3. echo $?
  
Actual results:
1

Expected results:
6 / status of the amd

Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is implemented correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html
Comment 1 Karel Zak 2007-05-31 02:02:02 EDT
*** Bug 237757 has been marked as a duplicate of this bug. ***
Comment 4 RHEL Product and Program Management 2010-08-09 14:44:20 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2011-01-11 16:15:24 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2011-01-11 17:15:47 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 7 RHEL Product and Program Management 2011-05-31 09:49:58 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 Karel Zak 2012-02-23 10:02:42 EST
*** Bug 237758 has been marked as a duplicate of this bug. ***
Comment 11 RHEL Product and Program Management 2013-04-09 14:27:22 EDT
Quality Engineering Management has reviewed and declined this request.
You may appeal this decision by reopening this request.
Comment 12 RHEL Product and Program Management 2013-04-09 14:29:28 EDT
Quality Engineering Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.