Bug 237757 - Wrong init script
Summary: Wrong init script
Status: CLOSED DUPLICATE of bug 237756
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: am-utils   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Karel Zak
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 237789 237758 237759
TreeView+ depends on / blocked
 
Reported: 2007-04-25 09:21 UTC by Michal Marciniszyn
Modified: 2014-02-10 23:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-31 06:02:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Marciniszyn 2007-04-25 09:21:16 UTC
Description of problem:
Init script does not return correct error codes and has wrong status implementation.

Version-Release number of selected component (if applicable):
All

How reproducible:
Always

Steps to Reproduce:
1. rename conf file (/etc/amd.conf)
2. service amd start / service amd status
3. echo $?
  
Actual results:
1

Expected results:
6 / status of the amd

Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is implemented correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

Comment 1 Karel Zak 2007-05-31 06:02:00 UTC

*** This bug has been marked as a duplicate of 237756 ***


Note You need to log in before you can comment on or make changes to this bug.