Bug 237809 - Wrong init script
Summary: Wrong init script
Status: CLOSED DUPLICATE of bug 247040
Alias: None
Product: Fedora
Classification: Fedora
Component: quagga   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Martin Bacovsky
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 237805
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-25 15:02 UTC by Michal Marciniszyn
Modified: 2014-02-10 23:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-26 13:32:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Marciniszyn 2007-04-25 15:02:34 UTC
+++ This bug was initially created as a clone of Bug #237805 +++

Description of problem:
If the /etc/quagga/bgpd.conf does not exist or the networking is shut down, then
the script always ends with error code 0 (even if status is invoked). There are
also wrong return codes in the script.

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1. service network stop
2. service bgpd start/status...
3. echo $0
  
Actual results:
0

Expected results:
non-zero exit code due to our guidelines or status of the service

Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.

Comment 1 Martin Bacovsky 2007-07-26 13:32:35 UTC

*** This bug has been marked as a duplicate of 247040 ***


Note You need to log in before you can comment on or make changes to this bug.