This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 237805 - Wrong init script
Wrong init script
Status: CLOSED DUPLICATE of bug 243143
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: quagga (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Bacovsky
:
Depends On:
Blocks: 237789 237808 237809
  Show dependency treegraph
 
Reported: 2007-04-25 10:59 EDT by Michal Marciniszyn
Modified: 2014-02-10 18:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 09:06:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Marciniszyn 2007-04-25 10:59:26 EDT
Description of problem:
If the /etc/quagga/bgpd.conf does not exist or the networking is shut down, then
the script always ends with error code 0 (even if status is invoked). There are
also wrong return codes in the script.

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1. service network stop
2. service bgpd start/status...
3. echo $0
  
Actual results:
0

Expected results:
non-zero exit code due to our guidelines or status of the service

Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.
Comment 1 Martin Bacovsky 2007-06-21 09:06:30 EDT

*** This bug has been marked as a duplicate of 243143 ***
Comment 2 Martin Bacovsky 2007-06-22 09:36:39 EDT
The inistcript is wrong but just FYI:
service network stop doesn't affect value of NETWORKING variable in
/etc/sysconfing/network so [ "${NETWORKING}" = "no" ] && exit 1 can pass even
with  network down.

Note You need to log in before you can comment on or make changes to this bug.