Bug 237839 - unicode_start invocations cause monitor to flicker/blank shortly with almost every init script called during boot
Summary: unicode_start invocations cause monitor to flicker/blank shortly with almost ...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: Patch
: 238300 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-25 16:28 UTC by Nils Philippsen
Modified: 2014-03-17 03:06 UTC (History)
3 users (show)

Fixed In Version: 8.64-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-27 16:32:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed fix (1.37 KB, patch)
2007-04-28 07:48 UTC, Nils Philippsen
no flags Details | Diff

Description Nils Philippsen 2007-04-25 16:28:10 UTC
Description of problem:

All init scripts call (through /etc/profile.d/lang.sh if /etc/sysconfig/i18n is
present) unicode_start which causes my monitor (CRT) to flicker/blank shortly,
it seems to re-synchronize every time (not sure whether that's harmful or not,
I'd be happier if it wouldn't do it that often ;-)).

Version-Release number of selected component (if applicable):
initscripts-8.45.7-1

How reproducible:
Probably easy, it may depend on the graphics card used, I only have one ATI
Radeon X800 GTO PCIe with which to test.

Steps to Reproduce:
1. attach CRT to main video output
2. boot
  
Actual results:
Almost every init script invoked causes the screen to flicker/blank.

Expected results:
No unnecessary flickering/blanking shortly.

Additional info:
/etc/rc.d/rc already makes a call to /etc/profile.d/lang.sh via
/etc/init.d/functions, you could perhaps subsequently export NOLOCALE=1 to the
start/stop scripts which would avoid unnecessarily sourcing lang.sh and calling
unicode_start.

Comment 1 Bill Nottingham 2007-04-25 16:56:05 UTC
There are some fixes in this regard in the F7 devel tree - you may want to try
F7 test 4.

Comment 2 Nils Philippsen 2007-04-26 06:28:17 UTC
Fixes regarding the scripts or regarding unicode_start? I looked at the
initscripts there (of course this machine wasn't showing the problem as it has
an LCD, not a CRT) and it seemed to me like lang.sh/unicode_start was called
there every time as well.

Comment 3 Bill Nottingham 2007-04-26 13:21:00 UTC
Changes to how/when the lang stuff is called - we don't always evaluate
everything if LANG is already set, for example.

Comment 4 Nils Philippsen 2007-04-26 15:54:02 UTC
From looking at Rawhide's /etc/profile.d/lang.sh (and how it differs to the one
in FC-6), unicode_start is explicitely called if a) LANG is set or
/etc/sysconfig/i18n or $HOME/.i18n exist and b) LANG is set to a UTF-8 value. I
think it's fair to assume that the problem will show on F7 as well. When test4
comes out, I can test a LiveCD on the system, though.

Comment 5 Nils Philippsen 2007-04-27 20:02:28 UTC
I've just tried it with the F7 test4 Live CD and found the same problem as on
FC6, as expected. Shall I clone the bug for Rawhide?

Comment 6 Nils Philippsen 2007-04-28 07:48:48 UTC
Created attachment 153688 [details]
proposed fix

Patch for initscripts that sources lang.sh once at the beginning of the rc
script and avoids sourcing it again via the functions scriptlet:

1.) rc sources lang.sh
2.) rc exports LANGSH_SOURCED=1
...
n.) init script avoids sourcing lang.sh due to set LANGSH_SOURCED
n+1.) init script unsets LANGSH_SOURCED to avoid propagation which could
"pollute" further invocations of init scripts
...

Makes sense?

Comment 7 Nils Philippsen 2007-04-28 07:50:51 UTC
Note that the patch is against "upstream" CVS HEAD.

Comment 8 Nils Philippsen 2007-07-12 13:55:13 UTC
This problem still exists. Shall I just implement what I described in comment
#6, try it out and commit it to CVS (and build)?

Comment 9 Bill Nottingham 2007-07-12 19:46:32 UTC
For rawhide? Commit it, and I'll build at some point in the near future.

Comment 10 Nils Philippsen 2007-07-17 06:19:40 UTC
Still to elvis CVS? I see that the last change in there is from mid-May, is the
repository still active or has the upstream SCM been moved somewhere else?

Comment 11 Bill Nottingham 2007-07-17 14:56:41 UTC
Yes, elvis.

Comment 12 Nils Philippsen 2007-07-17 15:23:59 UTC
committed to elvis CVS

Comment 13 Dmitry Butskoy 2008-02-27 12:19:00 UTC
Nils,

As you already touched lang.sh file, could you, please, also consider the issue
reported in the bug #422141  ?

Comment 14 Bill Nottingham 2008-02-27 16:32:48 UTC
Fixed in 8.64-1.

Comment 15 cheguaka 2008-02-27 18:30:16 UTC
¿Could this be fixed in initscripts-8.45.17.EL-1.el5.rpm? In RHEL 5.1?

Comment 16 Bill Nottingham 2008-02-27 19:03:44 UTC
Nothing along these lines has changed in RHEL.

Comment 17 cheguaka 2008-02-27 21:36:18 UTC
Well, initscripts-8.45.17.EL-1.el5 have the same problem. Flickering start/stop
scripts.

Comment 18 Bill Nottingham 2008-02-27 21:45:48 UTC
Yes, but the fix is too invasive to backport to RHEL 5.

Comment 19 cheguaka 2008-02-29 08:34:47 UTC
Bug #238300 is a duplicate of this bug.

(Meanwhile cheguaka returns to rhgb :p )

Comment 20 Bill Nottingham 2008-02-29 15:17:24 UTC
*** Bug 238300 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.