Bug 238300 - setfont makes screen flicker
setfont makes screen flicker
Status: CLOSED DUPLICATE of bug 237839
Product: Fedora
Classification: Fedora
Component: kbd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
:
: 245478 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-28 22:30 EDT by n0dalus
Modified: 2008-02-29 10:17 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-29 10:17:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description n0dalus 2007-04-28 22:30:08 EDT
Description of problem:
During startup/shutdown, the screen flickers like crazy. I managed to track down
what was causing it:
Init scripts -> /etc/init.d/functions -> /etc/profile.d/lang.sh ->
/bin/unicode_start -> /bin/setfont.

Every time /bin/setfont is called, the screen "resets", flickering. This may be
because of my graphics hardware, but the problem should be avoidable -- if the
font hasn't been changed, don't ask the kernel to change it. If it's not
possible to tell what the previous font was from userspace, this bug will need
to be fixed in the kernel (please change the bug component in that case).

Version-Release number of selected component (if applicable):
kbd-1.12-21
kernel-2.6.20-1.3104.fc7
Comment 1 n0dalus 2007-04-28 22:32:32 EDT
Fixed summary -- sorry for the bugspam.
Comment 2 Vitezslav Crhonek 2007-06-12 12:34:43 EDT
Hi,

there's no problem to read current font to user space. But your proposed
solution will not help, because the screen resets when you are reading font to
user space too, not only when you are loading new one into kernes space. Try:

setfont -o foo.bar

Also it looks like very hardware depending problem, on some machines no
flickering, on my machine time to time...

On your machine screen resets everytime you call setfont?
Comment 3 n0dalus 2007-06-12 21:50:37 EDT
You're right that there's not much that can be done about the problem in setfont
if reading the font causes the flicker.

There are two other solutions to the problem though:
1) Only call setfont once on boot, and then don't call it again. This would fix
the described problem of constant flickering on boot. There should be no reason
to need to repeatedly set the font -- if there is, that's a bug in something else.

2) Implement a solution in the kernel
The vgacon_do_font_op function makes a lot of VGA calls regardless of whether
the font is being 'get' or 'set'.
http://lxr.linux.no/source/drivers/video/console/vgacon.c?v=2.6.18#L1078

It's very likely that some of those commands are not necessary when just reading
the font memory. I'm not sure who would be most qualified to make some changes here.
Comment 4 Adam Pribyl 2008-02-27 04:05:48 EST
*** Bug 245478 has been marked as a duplicate of this bug. ***
Comment 5 cheguaka 2008-02-27 11:24:37 EST
The bug is filled against Fedora rawhide, but I have this bug now in RHEL 5.1. I
had previously F7 and F8. F7 had this bug for sure. But I remember somewhere
between F7 and F8 this bug was solved. ¿Perhaps initscripts-8.54.1-1.i386.rpm? I
can do some testing in RHEL 5.1 if required.
Comment 6 cheguaka 2008-02-27 13:15:05 EST
Some research here.

Look at bug #237839 

Comment #14 From Bill Nottingham (notting@redhat.com)  	 on 2008-02-27 11:32
EST  	[reply]  	 

Fixed in 8.64-1.
Comment 7 Bill Nottingham 2008-02-29 10:17:23 EST

*** This bug has been marked as a duplicate of 237839 ***

Note You need to log in before you can comment on or make changes to this bug.