Bug 237933 - conman init script uses some incorrect exit codes
Summary: conman init script uses some incorrect exit codes
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conman   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Jarod Wilson
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
: 244459 (view as bug list)
Depends On:
Blocks: 237789 237934 237936 244459
TreeView+ depends on / blocked
 
Reported: 2007-04-26 08:33 UTC by Michal Marciniszyn
Modified: 2014-02-10 23:02 UTC (History)
2 users (show)

Fixed In Version: RHBA-2007-0585
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-05 15:34:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0585 normal SHIPPED_LIVE conman bug fix update 2007-10-31 13:38:04 UTC

Description Michal Marciniszyn 2007-04-26 08:33:40 UTC
Description of problem:
On several occasions, the script may end up with error code 0 even when the
service is not started. As an example line:
[ ${NETWORKING} = "no" ] && exit 0
and some others. Also the return codes do not obbey our guidlines. Also note,
that the status command of the service should always return correct value, even
if the service itself cannot be started.

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1. service network stop
2. service conman start/status
3. echo $?
  
Actual results:
0

Expected results:
non-zero error code due to our guidlines/status of the service

Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.

Comment 2 Jarod Wilson 2007-06-04 20:43:25 UTC
Changes committed and new package built.

Comment 3 RHEL Product and Program Management 2007-06-05 20:29:28 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.

Comment 4 Jarod Wilson 2007-06-07 22:03:25 UTC
Seriously? This is a 2-line patch that changes exit codes in the initscript and
the work is already all done. This automated stuff is rather obnoxious.

Comment 7 Jarod Wilson 2007-06-15 19:43:20 UTC
*** Bug 244459 has been marked as a duplicate of this bug. ***

Comment 11 Red Hat Bugzilla 2007-07-05 15:34:37 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0585.html



Note You need to log in before you can comment on or make changes to this bug.