Bug 237974 - Wrong init script
Wrong init script
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dhcdbd (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks: 237789 237976 237977
  Show dependency treegraph
 
Reported: 2007-04-26 08:38 EDT by Michal Marciniszyn
Modified: 2014-02-10 18:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 16:58:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dhcdbd-2.2-initscript.patch (5.07 KB, patch)
2007-09-25 15:36 EDT, David Cantrell
no flags Details | Diff

  None (edit)
Description Michal Marciniszyn 2007-04-26 08:38:36 EDT
Description of problem:
If the networking is down, the script ends with error code 0 even though the
service is not started. The reason is:
[ "${NETWORKING}" = "no" ] && exit 0
Also the error code for unimplemented feature of the script is not correct, it
should be 3 instead of one at the end of the script.

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1. service network stop
2. service dhcdbd start/status
3. echo $?

Actual results:
0

Expected results:
correct non-zero error code/status of the service

Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.
Comment 1 David Cantrell 2007-09-25 15:36:55 EDT
Created attachment 205951 [details]
dhcdbd-2.2-initscript.patch
Comment 2 RHEL Product and Program Management 2007-12-03 15:42:25 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 3 David Cantrell 2008-12-03 16:58:56 EST
dhcdbd is obsoleted by the NetworkManager rebase in RHEL 5.3.  Further, dhcdbd won't be present in RHEL 6.0.  Given the low impact of this bug, I'm just going to close it because I see no reason to tie up QA resources to update the init script (and we haven't seen any interest from PM or QA to get this bug fixed up in 5.1 through 5.3, so I see no reason to keep it open).

Note You need to log in before you can comment on or make changes to this bug.