Bug 237977 - Wrong init script
Summary: Wrong init script
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcdbd (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 237974
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-26 12:40 UTC by Michal Marciniszyn
Modified: 2014-02-10 23:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-26 17:53:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Marciniszyn 2007-04-26 12:40:02 UTC
+++ This bug was initially created as a clone of Bug #237974 +++

Description of problem:
If the networking is down, the script ends with error code 0 even though the
service is not started. The reason is:
[ "${NETWORKING}" = "no" ] && exit 0
Also the error code for unimplemented feature of the script is not correct, it
should be 3 instead of one at the end of the script.

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1. service network stop
2. service dhcdbd start/status
3. echo $?

Actual results:
0

Expected results:
correct non-zero error code/status of the service

Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.

Comment 1 David Cantrell 2007-04-26 17:53:10 UTC
Fixed in rawhide in dhcdbd-2.7-2.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.