Bug 238066 - Clean install of Eclipse 3.2.2 fails to start
Clean install of Eclipse 3.2.2 fails to start
Status: CLOSED DUPLICATE of bug 238107
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-26 17:22 EDT by Edward Hildum
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-30 12:33:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error log from ~/workspace/.metadata (55.15 KB, text/plain)
2007-04-26 17:22 EDT, Edward Hildum
no flags Details

  None (edit)
Description Edward Hildum 2007-04-26 17:22:50 EDT
Description of problem:


Version-Release number of selected component (if applicable):
eclipse-sdk.i386 1:3.2.2-1.fc6

How reproducible:
I've done this now 3 times.

Steps to Reproduce:
1. On FC6 freshly upgraded from FC5, remove all eclipse packages and dependencies.
2. Delete all remaining eclipse and workspace directories in user directories
and delete /usr/share/eclipse.
3. do a fresh install of eclipse using yum install eclipse-pde-devel eclipse-cdt
  
Actual results:
Eclipse platform displays an error popup on startup: 
        An error has occurred. See the log file
        /root/workspace/.metadata/.log.



Expected results:
Platform starts and displays welcome window.

Additional info:
Comment 1 Edward Hildum 2007-04-26 17:22:50 EDT
Created attachment 153555 [details]
Error log from ~/workspace/.metadata
Comment 2 Ben Konrath 2007-04-27 00:13:12 EDT
Ok, it's a little strange that you're running eclipse as root. You shouldn't do
that if you can help it because eclipse will write configuration files to
/usr/share/eclipse/ which will mess up eclipse for other users on the system. 

Here's what you should do:

* remove eclipse again:
sudo yum remove eclipse-rcp libswt3-gtk2 eclipse-ecj

* manually delete /usr/share/eclipse and /usr/lib/eclipse
sudo rm -r /usr/share/eclipse /usr/lib/eclipse

* install eclipse
sudo yum install eclipse-sdk eclipse-cdt

* run eclipse as a normal user. If you still have a problem then you should move
~/.eclipse to out of the way and try again:
mv ~/.eclipse{,.bak}

If this works I'd like to see your backed up ~/.eclipse. Please report back.
Thanks, Ben
Comment 3 Edward Hildum 2007-04-27 11:38:20 EDT
Yeah, I know I shouldn't run it as root, but its the only way to install
subclipse.  If you run it as a normal user, the subclipse installation fails
with an error message that it doesn't have write permission on some directory
(don't remember which).  I notice that there is an update for eclipse available
today.  I'll follow up after I've run through your instructions.

Thanks, Ted
Comment 4 Edward Hildum 2007-04-27 12:54:44 EDT
I've followed the steps above, and eclipse now starts up correctly.  There are,
however, some additional problems.  I will put in a new bug report on those now.
Comment 5 Ben Konrath 2007-04-27 20:07:35 EDT
Ok, so can we close this bug?
Comment 6 Edward Hildum 2007-04-30 12:31:06 EDT
Go ahead and close it.  It sounds as if you have identified the problem.  I'll
test the latest release when it hits the update sites.
Comment 7 Ben Konrath 2007-04-30 12:33:45 EDT

*** This bug has been marked as a duplicate of 238107 ***

Note You need to log in before you can comment on or make changes to this bug.