Bug 238107 - update manager doesn't work
update manager doesn't work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
6
All Linux
high Severity urgent
: ---
: ---
Assigned To: Ben Konrath
:
: 238066 238169 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-27 04:18 EDT by Ben Konrath
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.2.2-5.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-16 03:44:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Konrath 2007-04-27 04:18:59 EDT
Description of problem:

There are two problems with the launcher-addplatformtotildeeclipse.patch:

1) There is a reference to org.eclipse.rcp_3.2.1.r321_v20060801-clWbqCmjexIWDqg
rather than org.eclipse.rcp_3.2.2.r322_v20070104-iwP0VLKnfFC923K.

2) The script shouldn't modify configuration/platform.xml if the script can be
sure that it has started from a clean slate at some point in the past. The patch
only needs a small modification to fix this. 

The combination of these two problems causes the update manager to stop working.

Version-Release number of selected component (if applicable):

eclipse-3.2.2-2.fc6

How reproducible:

always

Steps to reproduce:

1) rm -r ~/.eclipse
2) start eclipse and close it right away
3) start eclipse again
4) the configuration/platform.xml shouldn't be modified in this case
Comment 1 Ben Konrath 2007-04-27 04:49:42 EDT
A build is underway to fix this.
Comment 2 Ben Konrath 2007-04-27 19:38:26 EDT
*** Bug 238169 has been marked as a duplicate of this bug. ***
Comment 3 Ben Konrath 2007-04-30 11:42:19 EDT
Ok, the fix I made didn't address all of the issues so I'm still working on this. 

Here is the test plan for the fix:

1) ensure update manager works if there 
org.eclipse.rcp_3.2.1.r321_v20060801-clWbqCmjexIWDqg in platform.xml
  -> install eclipse-3.2.2-2.fc6
  -> ensure org.eclipse.rcp_3.2.1.r321_v20060801-clWbqCmjexIWDqg is in 
     platform.xml:
     grep -r rcp_3.2.1  
~/.eclipse/org.eclipse.platform_3.2.0/configuration/org.eclipse.update/platform.xml
  -> if not, running eclipse twice should put rcp_3.2.1 in platform.xml
  -> install eclipse-3.2.2-4.fc6
  -> start eclipse and ensure 3.2.1.r321_v20060801-clWbqCmjexIWDqg is not in 
     platform.xml
  -> ensure that the update manager works

2) ensure that platform.xml is not modified if started from a clean .eclipse
   -> install eclipse-3.2.2-4.fc6
   -> rm -r ~/.eclipse
   -> run eclipse
   -> check timestamp of
~/.eclipse/org.eclipse.platform_3.2.0/configuration/org.eclipse.update/platform.xml
   -> close eclipse and start again
   -> ensure that the timestamp of
~/.eclipse/org.eclipse.platform_3.2.0/configuration/org.eclipse.update/platform.xml
is the same
   -> ensure that 3.2.1.r321_v20060801-clWbqCmjexIWDqg is not in platform.xml

3) ensure that original bug is fixed
   -> install 3.2.1-4.fc6
   -> rm -r ~/.eclipse
   -> start eclipse 
   -> close eclipse
   -> update to eclipse-3.2.2-4.fc6
   -> ensure update manager works
Comment 4 Ben Konrath 2007-04-30 12:33:47 EDT
*** Bug 238066 has been marked as a duplicate of this bug. ***
Comment 5 Ben Konrath 2007-05-02 09:01:06 EDT
The second test plan should be this:

2) ensure that update manager works with a new configuration
   -> install eclipse-3.2.2-5.fc6
   -> rm -r ~/.eclipse
   -> run eclipse
   -> close eclipse
   -> run eclipse again
   -> ensure org.eclipse.rcp_3.2.1.r321_v20060801-clWbqCmjexIWDqg is not in 
     platform.xml:
     grep rcp_3.2.1 \
~/.eclipse/org.eclipse.platform_3.2.0/configuration/org.eclipse.update/platform.xml
   -> ensure that the update manager works
Comment 6 Ben Konrath 2007-05-02 09:25:22 EDT
eclipse-3.2.2-5 passes this test plan so I'm going to push it to the fc6 updates
final. 
Comment 7 Edward Hildum 2007-05-02 12:42:08 EDT
I updated my installation to eclipse-3.2.2-5 and was able to install the
subclipse 1.2.0 plug-in with the update procedure.  There seem to be some
(unrelated?) anomalies in the configuration, but I'll submit a separate bug report.

Thanks for your efforts Ben,
Ted Hildum
Comment 8 Fedora Update System 2007-05-07 22:10:20 EDT
eclipse-3.2.2-5.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.