Bug 238080 - rescue CD-ROM hangs starting network interface
rescue CD-ROM hangs starting network interface
Status: CLOSED DUPLICATE of bug 240804
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-26 19:23 EDT by John Reiser
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 16:27:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2007-04-26 19:23:19 EDT
Description of problem:  Booting from the rescue cd-rom, the system hangs when
attempting to start eth0.


Version-Release number of selected component (if applicable):
anaconda-11.2.0.55
F-6.93-x86_64-rescuecd.iso  2007-04-26  6ce7acb3ac9cb8a2630f6ccfb8e64081d0aa0128
 [sha1sum]

How reproducible: always


Steps to Reproduce:
1. boot rescue cd-rom
2. choose language, keyboard; start network, IPv4 only, DHCP
3.
  
Actual results: hang Starting Interface, "Attempting to start eth0"; no progress
after waiting 5 minutes.  "top" run from shell on C-A-F2 shows ananconda
spinning at 99% CPU.  C-A-F4 shows "<7>eth0: no IPv6 routers present".


Expected results: Network interface configured and started; rescue mode proceeds.


Additional info: Hardware is nVidia CK804; consumer-grade router+switch provides
DHCP server.  Drivers [firewire], sata_nv, pata_amd were loaded automatically. 
Runs fine when booted from installed system.
Comment 1 David Cantrell 2007-04-26 20:55:01 EDT
Known, worked on it today.  Have it working mostly, need more testing.  Will
commit fix tomorrow.
Comment 2 David Cantrell 2007-04-27 15:59:18 EDT
So static network configuration is working now, but DHCP still hangs for some
reason.  It could be that I'm using a system with an e1000 NIC, but I don't
know.  Can you test out rawhide tomorrow and see if the rescue CD works for you
to bring up the network?
Comment 3 Ron Yorston 2007-04-28 05:23:47 EDT
I noticed this same problem with the f7t4 rescue CD, though I'm using the i386
version and have a Realtek 8139 NIC.  The FC-development-i386-rescuecd.iso dated
27/4/07, sha1sum 7505063e7624c077d4bc191e43a6756d5c3baa9c has the same problem.

My DHCP server logs show a DISCOVER, OFFER, REQUEST, ACK sequence that looks OK
to me.

David says 'static network configuration is working now'.  It wasn't broken for
me:  both the f7t4 and 27/4/07 rescue CDs handle static configuration just fine.
Comment 4 John Reiser 2007-04-28 10:42:01 EDT
Today's (2007-04-28) Rawhide FC-development-i386-rescuecd.iso for i386,
102502400 bytes, sha1sum 9b187693be8ec6c79c9be1d49bc04b10f10af8a5, shows no
improvement.  IPv4 DHCP (no IPv6) still hangs with ananconda spinning at 99%
CPU.  Manual configuration of IPv4 (no IPv6) succeeds.
Comment 5 John Reiser 2007-05-01 13:12:46 EDT
The problem persists in today's (2007-05-01) Rawhide
FC-development-i386-rescuecd.iso for i386, 102586368 bytes, sha1sum
9c6b7a9aa46dca5c21881d4031ddffb734b5603a.  This is contrary to the claim of the
daily rawhide report: 20070501 changes:
-----
anaconda-11.2.0.57-1
* Mon Apr 30 2007 Jeremy Katz <katzj@redhat.com> - 11.2.0.56-1
- Fix rescue mode networking (dcantrell, #238080)
-----
Comment 6 John Reiser 2007-05-02 10:33:17 EDT
The problem persists in today's (2007-05-02) Rawhide 
FC-development-i386-rescuecd.iso for i386, 102586368 bytes, sha1sum
552905763371fee09fb6bdfa5b1f2015693b93f6.  [The daily rawhide report for
20070502 did not show any changes to anaconda, but I re-tested anyway in case
there might have been some hiccup in mirroring, the push of new packages, or the
rawhide report itself.]
Comment 7 David Cantrell 2007-05-22 16:27:56 EDT

*** This bug has been marked as a duplicate of 240804 ***

Note You need to log in before you can comment on or make changes to this bug.