Bug 238101 - /etc/mock/defaults.cfg is missing setting for chroot resolv.conf
/etc/mock/defaults.cfg is missing setting for chroot resolv.conf
Status: CLOSED ERRATA
Product: Fedora Hosted Projects
Classification: Retired
Component: mock (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Clark Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-27 02:57 EDT by Tuomo Soini
Modified: 2013-01-09 23:17 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.7.1-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 16:04:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add setting for resolv.conf contents into defaults.cfg (441 bytes, patch)
2007-04-27 02:57 EDT, Tuomo Soini
no flags Details | Diff

  None (edit)
Description Tuomo Soini 2007-04-27 02:57:37 EDT
Description of problem:

Some software like openssl tests use dns queries quite heavily when being built.
By default mock writes /etc/resolv.conf pointing dns queries to 192.168.1.1.
That's problem when 192.168.1.1 is not dns server in network.

The problem is that defaults.cfg which is default configuration file doesn't
even have setting for resolv.conf contents in chroot.

Version-Release number of selected component (if applicable):

mock 0.6.13.

How reproducible:
Always.

Steps to Reproduce:
1. install and configure mock
2. try to rebuild openssl - it takes looong time.
Comment 1 Tuomo Soini 2007-04-27 02:57:37 EDT
Created attachment 153581 [details]
add setting for resolv.conf contents into defaults.cfg
Comment 2 Clark Williams 2007-06-07 16:11:27 EDT
How about we add an option to copy in the host /dev/resolv.conf? Something like:

   config_opts['use_host_resolv'] = True

Which would trigger a copy of resolv.conf from /etc/ to the chroot?
Comment 3 Tuomo Soini 2007-06-08 04:48:03 EDT
Very good idea. Other files needing same config treatment are:

/etc/hosts, sometimes resolver is not available on build host

/etc/localtime, time in mock root is several hours different from system time.
Comment 4 Fedora Update System 2007-06-14 17:12:17 EDT
mock-0.7.1-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Jesse Keating 2007-06-16 08:08:00 EDT
I can confirm that there is in fact a setting and if enabled (it is by default)
the host resolve.conf is indeed placed into the chroot and is functional.
Comment 6 Jesse Keating 2007-06-16 08:08:41 EDT
*** Bug 237663 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2007-06-21 16:03:50 EDT
mock-0.7.1-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.