Bug 237663 - mock chroot environment has broken /etc/resolv.conf
mock chroot environment has broken /etc/resolv.conf
Status: CLOSED ERRATA
Product: Fedora Hosted Projects
Classification: Retired
Component: mock (Show other bugs)
unspecified
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Clark Williams
:
: 238937 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-24 11:53 EDT by Carl Roth
Modified: 2013-01-09 23:16 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.7.1-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 16:04:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl Roth 2007-04-24 11:53:03 EDT
Description of problem:

Mock creates a chroot environment with the nameserver in /etc/resolv.conf
hard-coded to 192.168.1.1.  Why is this?

For sites that don't use that as a default LAN configuration, it causes builds
for software bits that require networking to fail.  A good example is emacs and
its dependent packages -- starting emacs in any form triggers a lookup on the
local hostname.

Version-Release number of selected component (if applicable):

mock-0.6.11-1.fc6

How reproducible:

Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Morris 2007-05-12 23:51:01 EDT
*** Bug 238937 has been marked as a duplicate of this bug. ***
Comment 2 Clark Williams 2007-06-07 16:23:38 EDT
I don't know why that gets created. 

We're looking at adding an option such as:

    config_opts['use_ost_resolv'] = True

To trigger a copy of resolv.conf from /etc to <chroot>/etc

Comment 3 Fedora Update System 2007-06-14 17:12:20 EDT
mock-0.7.1-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Jesse Keating 2007-06-16 08:08:38 EDT

*** This bug has been marked as a duplicate of 238101 ***
Comment 5 Fedora Update System 2007-06-21 16:03:54 EDT
mock-0.7.1-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.