Bug 238108 - font size / display resolution ratio inverted
font size / display resolution ratio inverted
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-27 04:21 EDT by Nils Philippsen
Modified: 2007-12-10 05:34 EST (History)
2 users (show)

See Also:
Fixed In Version: f8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 05:34:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Firefox window when started with 72dpi display resolution (54.09 KB, image/png)
2007-04-27 11:55 EDT, Nils Philippsen
no flags Details
Firefox window when started with 96dpi display resolution (49.67 KB, image/png)
2007-04-27 11:57 EDT, Nils Philippsen
no flags Details
Firefox window when started with 130dpi display resolution (43.60 KB, image/png)
2007-04-27 11:58 EDT, Nils Philippsen
no flags Details

  None (edit)
Description Nils Philippsen 2007-04-27 04:21:37 EDT
Description of problem:

When increasing the display resolution, the font size decreases, i.e. the more
screen estate (pixel-wise) you have, the smaller the fonts get, both inside and
outside the displayed document.

Version-Release number of selected component (if applicable):
firefox-1.5.0.10-5.fc6

How reproducible:
Easily

Steps to Reproduce:
1. Lather: In "Edit -> Preferences -> Fonts&Colors -> Advanced", set "Display
Resolution" to various values (with "Other", when asked about the length of the
line, avoid lengths less than 3cm/1.2in as the UI may get unreadable)
2. Rinse: Restart firefox
3. Repeat
  
Actual results:
With high resolutions (i.e. more pixels on a defined length), the fonts get smaller.

Expected results:
Fonts get larger with increased resolution.

Additional info:
Bonus points for avoiding unreadably small font sizes. Super Extra Bonus points
for avoiding font sizes so large that the UI elements don't fit on the screen ;-).
Comment 1 Matěj Cepl 2007-04-27 05:57:30 EDT

*** This bug has been marked as a duplicate of 107803 ***
Comment 2 Felix Miata 2007-04-27 09:20:17 EDT
I don't believe the reporter's complaint is in any way related to bug 107803. I
do believe that what he describes is WAD.

With higher resolution comes higher real DPI. This is normal for any operating
environment. If X doesn't correctly adjust DPI with an increase in resolution,
you can expect system and FF UI fonts to get smaller as resolution is raised,
because UI and system fonts are sized in pt, which are DPI dependant.

Web page font preference sizes in FF are not dependant on DPI because they are
defined in px rather than pt. However because more DPI means smaller px, one
must manually adjust the FF font size preferences upwards as resolution is
raised in order to maintain adequate font sizes in web pages.
Comment 3 Nils Philippsen 2007-04-27 11:47:48 EDT
Matej, sorry to reopen this one, but it's not the same as bug #107803, namely
that bug #107803 deals only with document font sizes IIUC and I see the problem
with fonts used in the UI outside the document. While they should either stay
the  same size or get larger with an increased resolution (I guess it's policy
whether you want the one or the other), the UI fonts get smaller with increased
resolution. I'll attach some screenshots to illustrate what I mean.
Comment 4 Nils Philippsen 2007-04-27 11:55:08 EDT
Created attachment 153633 [details]
Firefox window when started with 72dpi display resolution
Comment 5 Nils Philippsen 2007-04-27 11:57:03 EDT
Created attachment 153634 [details]
Firefox window when started with 96dpi display resolution
Comment 6 Nils Philippsen 2007-04-27 11:58:45 EDT
Created attachment 153635 [details]
Firefox window when started with 130dpi display resolution

Note that any resolution noticable higher than 130dpi makes the font almost
unreadable.
Comment 8 Matěj Cepl 2007-05-09 11:19:06 EDT
OK, sorry Nils, I have to be really thick, but after looking at the screenshots,
it really seems to me that it works as designed -- with higher resolution you
get smaller fonts. What did you expect? Could you elaborate a little bit on
what's the problem?

And regarding comment 3 -- no, you are not setting DPI of webapge (i.e., how
many pixels take it to make on CSS unit pt), this is DPI of whole screen. It is
remainder of the time, when X servers were so broken, that they couldn't get
their own DPI correctly, so some applications (LyX is other case here) were able
to adjust themselves to the correct DPI of the screen despite what X server
thought. Most of the X servers gets this correct most of the time, so although
it remains available (and usually on whole desktop level -- e.g., Advanced
settings of gnome-font-properties), it is rarely used, and IMHO firefox (and
LyX) should relly on the environmental setting. Which means, that this setting
SHOULD change size of the fonts of the user interface.

Yes, some people are misusing this for changing DPI in HTML, but it is not
intended purpose of it.

Closing this as WORKSFORME and try to persuade me otherwise before reopening it.
Comment 9 Nils Philippsen 2007-05-25 10:55:32 EDT
Reopening as discussed on IRC.
Comment 10 Matěj Cepl 2007-12-10 04:24:34 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 11 Nils Philippsen 2007-12-10 05:34:33 EST
firefox-2.0.0.10-2.fc8 doesn't offer setting display resolutions anymore, closing.

Note You need to log in before you can comment on or make changes to this bug.