Bug 238140 - USB harddisk not found
Summary: USB harddisk not found
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-04-27 13:42 UTC by Karsten Hopp
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: udev-106-4.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-09 10:08:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Karsten Hopp 2007-04-27 13:42:32 UTC
Description of problem:
udev aborts detection of USB harddisks when p.e.
/sys/devices/pci0000:00/0000:00:07.0/host0/target0:0:0/0:0:0:0/ioerr_cnt
isn't available:

wait_for_sysfs: waiting for
'/sys/devices/pci0000:00/0000:00:1d.7/usb5/5-7/5-7:1.0/host2/target2:0:0/2:0:0:0/ioerr_cnt'
failed

The USB harddisk isn't accessible at all after this error.

Comment 1 Harald Hoyer 2007-04-27 13:55:35 UTC
fixed in udev-106-3.fc7

Comment 2 Will Woods 2007-05-02 22:57:51 UTC
Karsten, can you update udev and confirm the fix?

Comment 3 Harald Hoyer 2007-05-03 08:44:12 UTC
karsten. please try udev-106-4.fc7

Comment 4 Karsten Hopp 2007-05-03 08:52:10 UTC
Yes,  udev-106-3.fc7 fixed the problem for me. But it caused problems for
others, see bug #238385
So udev-106-4.fc7 might be the better choice for F7, this works for me as well

I'll leave this bug in ASSIGNED to keep it on the blocker list. Please close
when udev-106-4.fc7 has been tagged for F7

Comment 5 Sebastian Vahl 2007-05-09 09:38:47 UTC
(In reply to comment #4)
> Yes,  udev-106-3.fc7 fixed the problem for me. But it caused problems for
> others, see bug #238385
> So udev-106-4.fc7 might be the better choice for F7, this works for me as well

udev-106-3.fc7 also causes bug #238849. This one is also fixed with
udev-106-4.fc7. So I would agree that udev-106-4.fc7 would be the better choice.

Comment 6 Karsten Hopp 2007-05-09 10:08:13 UTC
udev-106-4.fc7 is tagged for f7-final according to bug #238849
closing....


Note You need to log in before you can comment on or make changes to this bug.