Bug 238385 - udev-106-3.fc7 breaks hal
Summary: udev-106-3.fc7 breaks hal
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: udev   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords: EasyFix
: 238419 239124 239180 (view as bug list)
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2007-04-30 02:18 UTC by David Zeuthen
Modified: 2013-03-06 03:50 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-17 16:31:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Zeuthen 2007-04-30 02:18:46 UTC
When plugging in a USB harddisk, I get this

UEVENT[1177898292.106724] add     
/devices/pci0000:00/0000:00:03.3/usb4/4-4/4-4.2 (usb)
UEVENT[1177898292.106761] add      /class/usb_endpoint/usbdev4.14_ep00
(usb_endpoint)
UEVENT[1177898292.114574] add     
/devices/pci0000:00/0000:00:03.3/usb4/4-4/4-4.2/4-4.2:1.0 (usb)
UEVENT[1177898292.114608] add      /class/scsi_host/host12 (scsi_host)
UEVENT[1177898292.114624] add      /class/usb_endpoint/usbdev4.14_ep01
(usb_endpoint)
UEVENT[1177898292.114640] add      /class/usb_endpoint/usbdev4.14_ep81
(usb_endpoint)
UEVENT[1177898292.114655] add      /class/usb_device/usbdev4.14 (usb_device)
UDEV  [1177898292.116876] add     
/devices/pci0000:00/0000:00:03.3/usb4/4-4/4-4.2 (usb)
UDEV  [1177898292.172185] add      /class/scsi_host/host12 (scsi_host)
UDEV  [1177898292.208171] add      /class/usb_endpoint/usbdev4.14_ep00
(usb_endpoint)
UDEV  [1177898292.376295] add      /class/usb_endpoint/usbdev4.14_ep01
(usb_endpoint)
UDEV  [1177898292.400620] add      /class/usb_endpoint/usbdev4.14_ep81
(usb_endpoint)
UDEV  [1177898292.443680] add      /class/usb_device/usbdev4.14 (usb_device)
UEVENT[1177898297.110649] add     
/devices/pci0000:00/0000:00:03.3/usb4/4-4/4-4.2/4-4.2:1.0/host12/target12:0:0/12:0:0:0
(scsi)
UEVENT[1177898297.110688] add      /class/scsi_disk/12:0:0:0 (scsi_disk)
UDEV  [1177898297.119204] add      /class/scsi_disk/12:0:0:0 (scsi_disk)
UEVENT[1177898297.123259] add      /block/sdb (block)
UEVENT[1177898297.123291] add      /block/sdb/sdb1 (block)
UEVENT[1177898297.123308] add      /class/scsi_device/12:0:0:0 (scsi_device)
UEVENT[1177898297.123325] add      /class/scsi_generic/sg3 (scsi_generic)
UDEV  [1177898297.164476] add     
/devices/pci0000:00/0000:00:03.3/usb4/4-4/4-4.2/4-4.2:1.0/host12/target12:0:0/12:0:0:0
(scsi)
UDEV  [1177898297.253134] add      /class/scsi_device/12:0:0:0 (scsi_device)
UDEV  [1177898297.261459] add      /class/scsi_generic/sg3 (scsi_generic)
UDEV  [1177898297.392768] add      /block/sdb (block)
UDEV  [1177898297.545906] add      /block/sdb/sdb1 (block)

This is wrong, for

UEVENT[1177898292.114574] add     
/devices/pci0000:00/0000:00:03.3/usb4/4-4/4-4.2/4-4.2:1.0 (usb)

there's no corresponding UDEV meaning that something ate the event. 

This means that pieces in the stack above udev will fail and the device won't
get mounted. Marking this as a FC7 blocker. Thanks.

Comment 1 David Zeuthen 2007-04-30 02:28:42 UTC
Downgrading to udev-106-2.fc7 fixes this... so the regression was introduced in
your last update.

Comment 2 David Zeuthen 2007-04-30 02:56:11 UTC
In 05-udev-early.rules we have this

+ ACTION=="add", SUBSYSTEM=="?*", ENV{MODALIAS}=="?*", RUN+="modprobe $env{MODALIA
S}", OPTIONS="last_rule"

Removing OPTIONS="last_rule" fixes the problem. In 106-2.fc7 the modprobe rule
was in 50-udev.rules and without last_rule. 

I wonder why you added last_rule? It means that no other rules will ever get
applied, in particular, the ones in /etc/udev/rules.d/90-hal.rules will not get
applied and that is what is causing this problem. So this should be easy to fix.
Marking bug as such. Thanks!


Comment 3 David Zeuthen 2007-04-30 15:31:39 UTC
*** Bug 238419 has been marked as a duplicate of this bug. ***

Comment 4 David Zeuthen 2007-04-30 15:32:28 UTC
Harald?

Comment 5 Harald Hoyer 2007-05-02 10:03:49 UTC
hmm... ok, had another problem with usb harddisks, which required the "last_rule"

Comment 6 Harald Hoyer 2007-05-02 11:43:47 UTC
udev-106-4.fc7

Comment 7 David Zeuthen 2007-05-02 15:33:38 UTC
(In reply to comment #5)
> hmm... ok, had another problem with usb harddisks, which required
> the "last_rule"

Just curious, what problem was this? In general, one should never use
"last_rule" at all since there's no way of knowing what rules will follow..


Comment 8 Harald Hoyer 2007-05-02 16:00:51 UTC
ACTION=="add", SUBSYSTEM=="scsi", WAIT_FOR_SYSFS="ioerr_cnt"

was done after the modprobe, which timed out...


Comment 9 Harald Hoyer 2007-05-02 16:01:25 UTC
ACTION=="add", SUBSYSTEM=="scsi", WAIT_FOR_SYSFS="ioerr_cnt"

was done before the modprobe, which timed out...

Comment 10 Paul W. Frields 2007-05-04 14:52:49 UTC
Is 106-4.fc7 coming to a repo near us now that the merge is more or less complete?

Comment 11 David Zeuthen 2007-05-06 14:25:17 UTC
*** Bug 239180 has been marked as a duplicate of this bug. ***

Comment 12 David Zeuthen 2007-05-06 14:25:44 UTC
*** Bug 239124 has been marked as a duplicate of this bug. ***

Comment 13 Kevin Fenzi 2007-05-09 20:28:29 UTC
Note that you can test by downloading directly from koji: 
http://koji.fedoraproject.org/koji/buildinfo?buildID=3105


Comment 14 Jens Knutson 2007-05-10 07:44:47 UTC
Installed the rpms from the above Koji link - this fixed the problem for me.


Note You need to log in before you can comment on or make changes to this bug.