Bug 238167 - Fix up CIFS for "test_clear_page_dirty()" removal
Fix up CIFS for "test_clear_page_dirty()" removal
Status: CLOSED DUPLICATE of bug 239339
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Layton
Martin Jenner
:
Depends On: 239339
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-27 12:53 EDT by Jeff Layton
Modified: 2007-11-16 20:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-19 11:58:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Layton 2007-04-27 12:53:39 EDT
+++ This bug was initially created as a clone of Bug #224476 +++

Description of problem:
This fixes a known oops in CIFS code

commit cb876f451455b6187a7d69de2c112c45ec4b7f99
Author: Linus Torvalds <torvalds@woody.osdl.org>
Date:   Sat Dec 23 16:19:07 2006 -0800

    Fix up CIFS for "test_clear_page_dirty()" removal

    This also adds he required page "writeback" flag handling, that cifs
    hasn't been doing and that the page dirty flag changes made obvious.

    Acked-by: Steve French <smfltc@us.ibm.com>
    Acked-by: Dave Kleikamp <shaggy@linux.vnet.ibm.com>
    Signed-off-by: Linus Torvalds <torvalds@osdl.org>

-- Additional comment from steved@redhat.com on 2007-01-25 15:56 EST --
Created an attachment (id=146626)
Upstream patch


-- Additional comment from pm-rhel@redhat.com on 2007-01-25 16:05 EST --
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

-- Additional comment from jlayton@redhat.com on 2007-04-27 12:14 EST --
Explanation by Linus of why this is needed:

http://lists.samba.org/archive/linux-cifs-client/2006-December/001647.html

-- Additional comment from jlayton@redhat.com on 2007-04-27 12:45 EST --
Actually, I don't think this patch fixes an oops. From what I can tell it fixes
a possible data integrity issue. Without it, doing a fdatasync and possibly
simialr syscalls might not be reliable.

Please let me know if that's not the case...

It looks like the patch that required these changes went in ~2.6.5, so this may
be a RHEL4 issue as well. I'll clone this BZ and we'll see if this is needed
there...
Comment 1 RHEL Product and Program Management 2007-05-08 16:26:14 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Jeff Layton 2007-06-19 11:58:50 EDT

*** This bug has been marked as a duplicate of 239339 ***

Note You need to log in before you can comment on or make changes to this bug.