Bug 239339 - update CIFS client to 1.48aRH
update CIFS client to 1.48aRH
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Layton
Martin Jenner
:
: 206123 238167 242110 246660 247610 293131 293151 (view as bug list)
Depends On:
Blocks: 222082 238167 242110
  Show dependency treegraph
 
Reported: 2007-05-07 13:41 EDT by Jeff Layton
Modified: 2010-10-22 10:46 EDT (History)
9 users (show)

See Also:
Fixed In Version: RHBA-2007-0791
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:26:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tarball with backport of 1.48 for older kernels (240.10 KB, application/octet-stream)
2007-06-18 14:48 EDT, Jeff Layton
no flags Details
patch -- update RHEL4 CIFS code to 1.48aRH (163.17 KB, patch)
2007-06-18 14:51 EDT, Jeff Layton
no flags Details | Diff
patch -- tweaks made to tarball to create RHEL4 patch (2.99 KB, patch)
2007-06-18 14:57 EDT, Jeff Layton
no flags Details | Diff
patch -- respin and include several late-breaking fixes (169.09 KB, patch)
2007-07-10 06:55 EDT, Jeff Layton
no flags Details | Diff
patch -- tweaks made to base tarball for respun patch (10.46 KB, patch)
2007-07-10 06:57 EDT, Jeff Layton
no flags Details | Diff
patch -- respin and include several late-breaking fixes (169.11 KB, patch)
2007-07-10 06:59 EDT, Jeff Layton
no flags Details | Diff

  None (edit)
Description Jeff Layton 2007-05-07 13:41:59 EDT
+++ This bug was initially created as a clone of Bug #238597 +++

This is a tracking BZ for tracking the update of the CIFS client code to 1.48a.
Given that that's how CIFS updates have generally been handled in the past, it's
probably best to continue that in RHEL5 as well.

-- Additional comment from jlayton@redhat.com on 2007-05-01 14:31 EST --
Setting flags and requesting exception for this for 5.1

-- Additional comment from jlayton@redhat.com on 2007-05-01 14:35 EST --
Created an attachment (id=153882)
patch -- update RHEL5 CIFS code to 1.48a

This patch updates the RHEL5 CIFS code to 1.48a. It should apply cleanly on top

of 2.6.18-17.el5. Cursory testing indicates that it works as expected. Still
working on more in-depth testing...


-- Additional comment from pm-rhel@redhat.com on 2007-05-01 14:44 EST --
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

-- Additional comment from jlayton@redhat.com on 2007-05-07 12:44 EST --
Created an attachment (id=154279)
patch -- update RHEL5 CIFS code to 1.48aRH

This is essentially identical to the other patch, but I folded in the patch for
bug #227973, and customized the version string.
Comment 1 Jeff Layton 2007-05-07 13:43:21 EDT
Opening similar bug for RHEL4, but if the deadline permits we may go with a
later rev than 1.48.
Comment 2 Jeff Layton 2007-06-18 07:24:52 EDT
*** Bug 242110 has been marked as a duplicate of this bug. ***
Comment 3 Jeff Layton 2007-06-18 14:48:04 EDT
Created attachment 157310 [details]
tarball with backport of 1.48 for older kernels

This tarball contains the original 1.48a code. It's a backport by Steve French
of the upstream 1.48 code to earlier kernels.
Comment 5 Jeff Layton 2007-06-18 14:51:32 EDT
Created attachment 157311 [details]
patch -- update RHEL4 CIFS code to 1.48aRH

This patch updates RHEL4's CIFS code to 1.48aRH. It should apply to latest
development kernels.
Comment 6 RHEL Product and Program Management 2007-06-18 14:54:57 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Jeff Layton 2007-06-18 14:57:26 EDT
Created attachment 157313 [details]
patch -- tweaks made to tarball to create RHEL4 patch

This patch reflects the changes that were made to the attached tarball to make
it work on RHEL4.

i.e.: if you replace the fs/cifs dir in a recent RHEL4 dev kernel and apply
this patch on top of it, then you'll end up with a patch like the larger update
patch. This patch also contains the fix that I rolled in to make anonymous
mounts work.
Comment 8 RHEL Product and Program Management 2007-06-18 15:36:12 EDT
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.
Comment 9 Jeff Layton 2007-06-18 15:37:29 EDT
Patch posted to RHKL:

Subject: [RHEL4.6 PATCH] Update CIFS to 1.48aRH (BZ 239339)
Comment 10 Jeff Layton 2007-06-19 11:59:02 EDT
*** Bug 238167 has been marked as a duplicate of this bug. ***
Comment 11 Jeff Layton 2007-07-10 06:55:20 EDT
Created attachment 158846 [details]
patch -- respin and include several late-breaking fixes

This patch is the same as the earlier patch, but includes a few late breaking
patches that have some security significance.
Comment 12 Jeff Layton 2007-07-10 06:58:00 EDT
Created attachment 158848 [details]
patch -- tweaks made to base tarball for respun patch

Respun "tweaks" patch, which includes the new deltas.
Comment 13 Jeff Layton 2007-07-10 06:59:51 EDT
Created attachment 158849 [details]
patch -- respin and include several late-breaking fixes

Respun respin...the last one was missing the delta that made the mount error
out if signing was specified but the server doesn't support it.
Comment 14 Jeff Layton 2007-07-10 07:10:48 EDT
*** Bug 247610 has been marked as a duplicate of this bug. ***
Comment 15 Jeff Layton 2007-07-10 07:10:59 EDT
*** Bug 246660 has been marked as a duplicate of this bug. ***
Comment 16 Jeff Layton 2007-07-10 07:11:44 EDT
*** Bug 206123 has been marked as a duplicate of this bug. ***
Comment 17 Jeff Layton 2007-07-19 10:05:00 EDT
Release note text:

Common Internet File System (CIFS) has been updated to version 1.48aRH
Comment 21 Jason Baron 2007-07-27 11:56:49 EDT
committed in stream U6 build 55.24. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/
Comment 24 Issue Tracker 2007-07-30 17:15:08 EDT
Hi David,

Got the hotfix released today, thanks to David Mair and Linda Wang for
their assistance and approval.  Please let us know if the customer runs
into any problems.  All the usual disclaimers apply (about hotfix expiring
30 days after next update etc) but I know you know them already.

--vince


This event sent from IssueTracker by vincew 
 issue 126574
Comment 28 Issue Tracker 2007-09-13 17:45:31 EDT
hotfix approved, in process of releasing now.  Linda Wang said use -58.EL
since this is the same kernel being given to partners to eval in snap2.

--vince


This event sent from IssueTracker by vincew 
 issue 130738
Comment 30 Mark J. Cox (Product Security) 2007-09-27 11:42:53 EDT
*** Bug 293131 has been marked as a duplicate of this bug. ***
Comment 31 Mark J. Cox (Product Security) 2007-10-04 06:39:22 EDT
*** Bug 293151 has been marked as a duplicate of this bug. ***
Comment 33 errata-xmlrpc 2007-11-15 11:26:24 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0791.html

Note You need to log in before you can comment on or make changes to this bug.