Bug 238169 - Directory permissions prevent adding subclipse via software update
Summary: Directory permissions prevent adding subclipse via software update
Status: CLOSED DUPLICATE of bug 238107
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse   
(Show other bugs)
Version: 6
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ben Konrath
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-27 17:09 UTC by Edward Hildum
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-27 21:13:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Edward Hildum 2007-04-27 17:09:04 UTC
Description of problem:
On a clean installation of eclipse installed using:
  > yum install eclipse-sdk eclipse-cdt
Using Help/Software Updates/Find and Install, the SDK displays an error
complaining that it can't create a directory under /usr/eclipse/features.  If
this is ignored, there is a configuration problem that prevents any features
from installing.  The reported configuration problems are:

Current configuration contains errors that are not corrected by the requested
operation and more errors would be introduced. See details for more information.
  ----- Current configuration problems -----
    Error creating feature
"file:/usr/share/eclipse/features/org.eclipse.rcp_3.2.1.r321_v20060801-clWbqCmjexIWDqg/".
[/usr/share/eclipse/features/org.eclipse.rcp_3.2.1.r321_v20060801-clWbqCmjexIWDqg/feature.xml
(No such file or directory)]
  ----- Configuration problems after the operation -----
    Error creating feature
"file:/usr/share/eclipse/features/org.eclipse.rcp_3.2.1.r321_v20060801-clWbqCmjexIWDqg/".
[/usr/share/eclipse/features/org.eclipse.rcp_3.2.1.r321_v20060801-clWbqCmjexIWDqg/feature.xml
(No such file or directory)]


Version-Release number of selected component (if applicable):
Version: 3.2.2
Build id: M20070212-1330 (Fedora Core release 6 (Zod))

How reproducible:
So far, I've only done this once on this version, but the same problem was
present on the previous update.

Steps to Reproduce:
1. On a fresh install of eclipse, installed as above, invoke /Help/Software
Updates/Find and Install.
2. Add a new remote link to http://subclipse.tigris.org/update
3. Click <Finish>
4. Select Subclipse
  
Actual results:
Popup indicates a configuration error.

Expected results:
SDK should proceed to downloading the selected feature.

Additional info:

Comment 1 Edward Hildum 2007-04-27 21:13:36 UTC
On closer examination, this isn't right.  The actual problem is that there are
missing plugins in the distribution.

Comment 2 Ben Konrath 2007-04-27 23:38:24 UTC
No, it is a bug. I just discovered it yesterday evening. I'm currently working
on a fix. Thanks for the report.

*** This bug has been marked as a duplicate of 238107 ***


Note You need to log in before you can comment on or make changes to this bug.