This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 238358 - Missing "/usr/include/libiptc/libiptc.h" in iptables-devel
Missing "/usr/include/libiptc/libiptc.h" in iptables-devel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: iptables (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 402281
  Show dependency treegraph
 
Reported: 2007-04-29 15:35 EDT by Ashish Shukla
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 05:19:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A plain C Program including iptables.h (39 bytes, text/x-csrc)
2007-04-29 15:35 EDT, Ashish Shukla
no flags Details

  None (edit)
Description Ashish Shukla 2007-04-29 15:35:15 EDT
Description of problem:
"/usr/include/libiptc/libiptc.h" is not available but it is referenced in
"/usr/include/iptables.h" . Due to this I'm not able to compile "miniupnpd" (
http://miniupnp.free.fr/ ).

Version-Release number of selected component (if applicable):
iptables-devel-1.3.5-1.2.1

How reproducible:
Try compiling "test.c" (attached)

Steps to Reproduce:
1. Download "test.c" .
2. Execute following command:
   gcc -c test.c
  
Actual results:
GCC emits following errors during compilation:

-- begin errors --
In file included from test.c:1:
/usr/include/iptables.h:5:29: error: libiptc/libiptc.h: No such file or directory
In file included from test.c:1:
/usr/include/iptables.h:21: error: ‘IPT_FUNCTION_MAXNAMELEN’ undeclared here
(not in a function)
/usr/include/iptables.h:23: error: expected specifier-qualifier-list before
‘u_int8_t’
/usr/include/iptables.h:39: error: expected specifier-qualifier-list before
‘ipt_chainlabel’
/usr/include/iptables.h:92: error: expected specifier-qualifier-list before
‘ipt_chainlabel’
/usr/include/iptables.h:154: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or
‘__attribute__’ before ‘parse_protocol’
/usr/include/iptables.h:158: error: expected declaration specifiers or ‘...’
before ‘iptc_handle_t’
/usr/include/iptables.h:173: error: expected ‘;’, ‘,’ or ‘)’ before ‘chain’
/usr/include/iptables.h:175: error: expected ‘;’, ‘,’ or ‘)’ before ‘chain’
/usr/include/iptables.h:177: error: expected declaration specifiers or ‘...’
before ‘iptc_handle_t’
/usr/include/iptables.h:178: error: expected declaration specifiers or ‘...’
before ‘iptc_handle_t’
-- end errors --

Expected results:
The program gets compiled without any errors.

Additional info:
The "iptables-dev" package of Debian has "/usr/include/libiptc/libiptc.h".
http://packages.debian.org/stable/devel/iptables-dev
http://packages.debian.org/cgi-bin/search_contents.pl?searchmode=filelist&word=iptables-dev&version=stable&arch=i386
Comment 1 Ashish Shukla 2007-04-29 15:35:15 EDT
Created attachment 153746 [details]
A plain C Program including iptables.h
Comment 2 Thomas Woerner 2007-08-29 10:48:43 EDT
Please have a look at iptables-1.3.8-2.fc6 in the testing tree.
Comment 3 Ashish Shukla 2007-08-31 23:36:29 EDT
Thanks "iptables-devel-1.3.8-2" now has all the include files. Will try
compiling miniupnp today, and report if any other iptables #include errors occurs.
Comment 4 Thomas Woerner 2007-09-10 05:19:25 EDT
Fixed in updates in package iptables-1.3.8-2.fc6.

Note You need to log in before you can comment on or make changes to this bug.