Bug 402281 - Missing "/usr/include/libiptc/libiptc.h" in iptables-devel
Missing "/usr/include/libiptc/libiptc.h" in iptables-devel
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iptables (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: iptables-maint-list
:
Depends On: 238358
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-28 02:19 EST by Norm Murray
Modified: 2010-10-22 16:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 06:59:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Mealing 2007-11-28 02:19:43 EST
Gday Guys,

The current version of iptables-devel in RHEL 5.1 does not incldue the libpt.h
file, although it does include /usr/lib/libiptc.a .

The customer is asking for this file to be included to compile against libiptc.



+++ This bug was initially created as a clone of Bug #238358 +++

Description of problem:
"/usr/include/libiptc/libiptc.h" is not available but it is referenced in
"/usr/include/iptables.h" . Due to this I'm not able to compile "miniupnpd" (
http://miniupnp.free.fr/ ).

Version-Release number of selected component (if applicable):
iptables-devel-1.3.5-1.2.1

How reproducible:
Try compiling "test.c" (attached)

Steps to Reproduce:
1. Download "test.c" .
2. Execute following command:
   gcc -c test.c
  
Actual results:
GCC emits following errors during compilation:

-- begin errors --
In file included from test.c:1:
/usr/include/iptables.h:5:29: error: libiptc/libiptc.h: No such file or directory
In file included from test.c:1:
/usr/include/iptables.h:21: error: ‘IPT_FUNCTION_MAXNAMELEN’ undeclared here
(not in a function)
/usr/include/iptables.h:23: error: expected specifier-qualifier-list before
‘u_int8_t’
/usr/include/iptables.h:39: error: expected specifier-qualifier-list before
‘ipt_chainlabel’
/usr/include/iptables.h:92: error: expected specifier-qualifier-list before
‘ipt_chainlabel’
/usr/include/iptables.h:154: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or
‘__attribute__’ before ‘parse_protocol’
/usr/include/iptables.h:158: error: expected declaration specifiers or ‘...’
before ‘iptc_handle_t’
/usr/include/iptables.h:173: error: expected ‘;’, ‘,’ or ‘)’ before ‘chain’
/usr/include/iptables.h:175: error: expected ‘;’, ‘,’ or ‘)’ before ‘chain’
/usr/include/iptables.h:177: error: expected declaration specifiers or ‘...’
before ‘iptc_handle_t’
/usr/include/iptables.h:178: error: expected declaration specifiers or ‘...’
before ‘iptc_handle_t’
-- end errors --

Expected results:
The program gets compiled without any errors.

Additional info:

-- Additional comment from twoerner@redhat.com on 2007-09-10 05:19 EST --
Fixed in updates in package iptables-1.3.8-2.fc6.
Comment 2 john.haxby@oracle.com 2008-11-17 10:43:29 EST
See also bug 462207
Comment 7 errata-xmlrpc 2009-09-02 06:59:40 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1414.html

Note You need to log in before you can comment on or make changes to this bug.