Bug 238384 - yum update yum breaks yum
yum update yum breaks yum
Status: CLOSED DUPLICATE of bug 238305
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-29 21:49 EDT by Jonathan Smith
Modified: 2014-01-21 17:58 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-29 22:11:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Smith 2007-04-29 21:49:36 EDT
Description of problem:


Version-Release number of selected component (if applicable):

  yum.noarch 0:3.1.7-1.fc7

How reproducible:

  Once was enough


Steps to Reproduce:
1. yum update yum
2.
3.
  
Actual results:

Updated: yum.noarch 0:3.1.7-1.fc7
Dependency Updated: yum-metadata-parser.i386 0:1.1.0-1.fc7
Complete!

Ah, good! As expected, but then...

$ sudo yum -y upgrade
Loading "installonlyn" plugin
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 82, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 159, in getOptionsConfig
    (opts, self.cmds) = self.optparser.setupYumConfig()
  File "/usr/share/yum-cli/cli.py", line 1134, in setupYumConfig
    self.base.setupProgessCallbacks()
  File "/usr/share/yum-cli/output.py", line 322, in setupProgessCallbacks
    self.repos.setProgressBar(TextMeter(fo=sys.stdout))
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 497, in <lambda>
    repos = property(fget=lambda self: self._getRepos(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 348, in _getRepo
s
    self.plugins.run('postreposetup')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 163, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fastestmirror.py", line 83, in postreposetup_hook
    repo.urls = repomirrors[str(repo)]
AttributeError: can't set attribute


Expected results:

normal yum upgrade procedure

Additional info:

Went to #fedora-devel for help. Mistake. Google search and found suggestion

sudo rpm -e yum yum-metadata-parser --nodeps

Then rpm.pbone.net search to find earlier versions

sudo rpm -ivh yum-3.1.2-1.fc7.noarch.rpm yum-metadata-parser-1.0.3-2.fc7.i386.rpm

And, back in business, able to update other packages, e.g., gcc, kernel, etc.
Comment 1 Seth Vidal 2007-04-29 22:11:33 EDT

*** This bug has been marked as a duplicate of 238305 ***

Note You need to log in before you can comment on or make changes to this bug.