Bug 238305 - yum-fastestmirror AttributeError
yum-fastestmirror AttributeError
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 238334 238384 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-28 23:33 EDT by Igor Foox
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-29 09:53:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Igor Foox 2007-04-28 23:33:28 EDT
Description of problem:
After upgrading to latest rawhide (from rawhide of a few weeks ago)
yum-fastestmirror breaks yum. The following message is displayed:

[ifoox@localhost ~]$ yum info pydev
Loading "fastestmirror" plugin
Loading "installonlyn" plugin
Loading mirror speeds from cached hostfile
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 82, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 159, in getOptionsConfig
    (opts, self.cmds) = self.optparser.setupYumConfig()
  File "/usr/share/yum-cli/cli.py", line 1134, in setupYumConfig
    self.base.setupProgessCallbacks()
  File "/usr/share/yum-cli/output.py", line 322, in setupProgessCallbacks
    self.repos.setProgressBar(TextMeter(fo=sys.stdout))
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 497, in <lambda>
    repos = property(fget=lambda self: self._getRepos(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 348, in _getRepos
    self.plugins.run('postreposetup')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 163, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fastestmirror.py", line 83, in postreposetup_hook
    repo.urls = repomirrors[str(repo)]
AttributeError: can't set attribute


Version-Release number of selected component (if applicable):
yum-fastestmirror-1.1.2-1.fc7 
yum-3.1.7-1.fc7.noarch


How reproducible:
Always.

Steps to Reproduce:
1. Update to latest rawhide with yum-fastestmirror installed.
2. Run any yum command.
3. Witness breakage.
4. rpm -e yum-fastestmirror
5. Run any yum command
6. Witness bliss, albeit slowly.
  
Actual results:
Yum working.

Expected results:
Yum broken.

Additional info:
Cleaning cache and running either as normal user or su doesn't make a difference.
Comment 1 Julius B. 2007-04-29 09:27:50 EDT
*** Bug 238334 has been marked as a duplicate of this bug. ***
Comment 2 Seth Vidal 2007-04-29 09:53:22 EDT
apply this patch to yum and it fixes it:
https://lists.dulug.duke.edu/pipermail/yum-cvs-commits/2007-April/001690.html

closing this upstream

thanks
Comment 3 Seth Vidal 2007-04-29 22:11:38 EDT
*** Bug 238384 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.