Bug 238426 - bulgarian.kbd (Invalid UTF-8 sequence)
Summary: bulgarian.kbd (Invalid UTF-8 sequence)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: aspell-bg   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-30 13:16 UTC by Nikolay Vladimirov
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-02 10:52:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nikolay Vladimirov 2007-04-30 13:16:01 UTC
Description of problem:
Aspell exits with error:
Error: /usr/lib64/aspell-0.60/bulgarian.kbd:4: The string "w�" is invalid.
Invalid UTF-8 sequence at position 2.


Version-Release number of selected component (if applicable):
aspell-0.60.5-3.fc7
aspell-en-6.0-7.fc7
aspell-bg-0.50-14.fc7

How reproducible:
Spell check a file with aspell using the bulgarian dictionary.

Steps to Reproduce:
1. Create an example file 'foo' 
Exsample foo content:
ново ффф

"ново" is correct, it means "new". "ффф" is incorrect. 

2. aspell -l bg -c foo
  
Actual results:
Error: /usr/lib64/aspell-0.60/bulgarian.kbd:4: The string "w�" is invalid.
Invalid UTF-8 sequence at position 2.

Expected results:
Mark "ффф" as misspelled 

Additional info:
If bulgarian.kbd is empty, aspell works fine

Comment 1 Doncho Gunchev 2007-05-01 16:54:37 UTC
I have no idea when bulgarian.kbd got filled with data, but I think I fixed this:

# recode cp1251/ /usr/lib64/aspell-0.60/bulgarian.kbd

It's in CP1251, while aspell needs it to be in UTF-8. It's quite simple, isn't it?
I can't rising the priority, but please do so because: a) it's very simple to
fix, b) it kills the spell check in kbabel (which I need to translate fedora),
kwrite... everywhere.

Comment 2 Nikolay Vladimirov 2007-05-01 21:47:12 UTC
I confirm that recoding bulgarian.kbd fixes the problem. 

Comment 3 Ivana Varekova 2007-05-02 10:52:32 UTC
Thanks. Fixed in aspell-bg-0.50-15.fc7.

Comment 4 Doncho Gunchev 2007-05-03 08:20:05 UTC
Thank you too ;-)

Comment 5 Ivana Varekova 2007-06-18 07:59:06 UTC
*** Bug 244569 has been marked as a duplicate of this bug. ***

Comment 6 Nikolay Vladimirov 2007-06-18 10:43:40 UTC
When will the updated package be available in the fedora 7 repository? The issue
was resolved more than a month ago. 

Comment 7 Doncho Gunchev 2007-06-19 13:51:19 UTC
Now the file is zero sized:
$ rpmverify aspell-bg-0.50-15.fc7
$ ls -al /usr/lib/aspell-0.60/bulgarian.kbd
-rw-r--r-- 1 root root 0  2 май 13,49 /usr/lib/aspell-0.60/bulgarian.kbd


Comment 8 Doncho Gunchev 2007-06-21 22:03:17 UTC
Filled in bug # 245257 .


Note You need to log in before you can comment on or make changes to this bug.