Bug 238451 - fbdev fails under xen
fbdev fails under xen
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-fbdev (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
: 239094 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-30 13:02 EDT by Bob Relyea
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-11 15:53:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X server's log (8.11 KB, text/plain)
2007-04-30 14:05 EDT, Michal Schmidt
no flags Details
Patch to fbdevhw.c (492 bytes, patch)
2007-04-30 15:44 EDT, Michal Schmidt
no flags Details | Diff
Xorg log from a debug build of the server (8.05 KB, text/plain)
2007-05-10 12:40 EDT, Daniel Berrange
no flags Details

  None (edit)
Description Bob Relyea 2007-04-30 13:02:09 EDT
Description of problem:

When trying to run Rawhide or Fedora 7 (Test3 or Test 4) under as a
paravirtualized client under a RHEL-5 host, X fails to start. Automatic recovery
doesn't.

Version-Release number of selected component (if applicable):

Test 2 works, Test 3 and Test 4 fail, and the rawhide tip fails.

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Michal Schmidt 2007-04-30 14:03:16 EDT
I'm seeing the same problem running Fedora 6.93 under FC6 host. Other 
paravirtualized guests (FC6, RHEL-5) work fine.
The X server fails with:
(EE) FBDEV(0): FBIOPUT_VSCREENINFO succeeded but modified mode
(EE) FBDEV(0): mode initialization failed
I'll attach the complete log.
Comment 2 Michal Schmidt 2007-04-30 14:05:08 EDT
Created attachment 153809 [details]
X server's log
Comment 3 Michal Schmidt 2007-04-30 15:44:33 EDT
Created attachment 153816 [details]
Patch to fbdevhw.c

This patch makes it work. I can now start X in paravirualized Fedora 6.93.
Comment 4 Adam Jackson 2007-05-08 12:09:01 EDT
*** Bug 239094 has been marked as a duplicate of this bug. ***
Comment 5 Daniel Berrange 2007-05-10 12:40:23 EDT
Created attachment 154484 [details]
Xorg log from a debug build of the server
Comment 6 Adam Jackson 2007-05-11 15:53:42 EDT
Fixed in 1.3.0.0-5. thanks!

Note You need to log in before you can comment on or make changes to this bug.