Bug 239094 - X server fails to start with Xen paravirtualized framebuffer in anaconda
Summary: X server fails to start with Xen paravirtualized framebuffer in anaconda
Status: CLOSED DUPLICATE of bug 238451
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-04 20:37 UTC by Daniel Berrange
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-08 16:08:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg logfile captured from anaconda (8.01 KB, text/plain)
2007-05-04 20:37 UTC, Daniel Berrange
no flags Details
Autogenerated X config file (740 bytes, text/plain)
2007-05-04 20:37 UTC, Daniel Berrange
no flags Details

Description Daniel Berrange 2007-05-04 20:37:01 UTC
Description of problem:
When attempting to install a rawhide paravirtualized guest with Xen, anaconda
detects the Xen framebuffer & tries to start X, but it fails & has to carry on
in text mode.

Version-Release number of selected component (if applicable):
Rawhide anaconda image 4-may-2007

How reproducible:
Always

Steps to Reproduce:
1.   virt-install --name f7pv \
         --ram 500 \
         --file=/var/lib/xen/images/f7pv.img \
         --file-size 5 \
         --vnc \
         --location
http://download.fedora.devel.redhat.com/pub/fedora/linux/core/development/x86_64/os/
\ 
         --paravirt

2. Go through anaconda stage1 until it tries to start X
3.
  
Actual results:
X fails to startup & install proceeeds in text mode

Expected results:
X starts & install proceeds in graphical mode

Additional info:
Will attach relevant logs...

Comment 1 Daniel Berrange 2007-05-04 20:37:01 UTC
Created attachment 154163 [details]
Xorg logfile captured from anaconda

Comment 2 Daniel Berrange 2007-05-04 20:37:52 UTC
Created attachment 154164 [details]
Autogenerated X config file

Comment 3 Adam Jackson 2007-05-08 16:08:48 UTC

*** This bug has been marked as a duplicate of 238451 ***


Note You need to log in before you can comment on or make changes to this bug.