This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 238526 - tetris-bsd is 'illegal' and shouldn't be included?
tetris-bsd is 'illegal' and shouldn't be included?
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: bsd-games (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Wart
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-30 23:45 EDT by vfiend
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 17:12:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description vfiend 2007-04-30 23:45:33 EDT
Gnometris apparently isn't included because there are legal issues ("All Tetris
clones are illegal", see bug 84407 and bug 148883) so doesn't this mean that
tetris-bsd shouldn't be included either? Tetris-bsd even uses the name 'tetris'
unlike gnometris.
Comment 1 Wart 2007-05-01 00:52:14 EDT
The use of the name 'tetris' is an oversight and will be corrected shortly.  As
for including the game itself, I've asked for some advice/clarification from the
Fedora community on whether this is allowed or not.
Comment 2 vfiend 2007-05-01 01:24:42 EDT
Well, I don't really know whether it's allowed or is illegal personally, I just
noticed that "All Tetris clones are illegal" was a quote a Red Hate developer
made in the other bug report.
Comment 3 Wart 2007-05-01 17:12:11 EDT
Based on the discussion on fedora-devel-list and bug #224627, it seems that it's
enough to remove all user-visible references to tetris in the game, while the
game itself can remain.

This has been done in the latest bsd-games-2.17-20 release.

Note You need to log in before you can comment on or make changes to this bug.